Unable to Navigate to Uboot Page After Following Debrick Guide

I am attempting to set up my new GL-MT3000 Beryl AX routers after failing to get the factory reset to work (multiple attempts made on both) and subsequently following the “debrick” instructions here Debrick via Uboot - GL.iNet Router Docs 4.

When I attempt factory resets (without Uboot), I see the correct sequence of lights, but when I try to connecting to my router (on my iphone and my macbook), I am prompted to enter a password - which I haven’t set yet. After waiting 5, 10, 20 minutes, I still was prompted for a password.

After trying this a couple times, I moved onto trying to use Uboot. After downloading the latest image here, and following the MacOS instructions, when I would navigate to in my browser, the page doesn’t load.

I’ve tried the full sequence of events multiple times, on both of my MT-3000 routers (I bought two, one for a server at home, and another to connect to this server from abroad).

What I’ve tried:

  • Restarting my router (ATT BGW320-505)
  • Double checking all of the Ethernet settings to make sure I had manually set the right IP address, subnet mask, and router IP address, according to the debrick instructions.
  • Trying a different browser (Firefox to Chrome)
  • Turning off my Wifi service on my mac, so just the AX88179A (My wired router to computer service via ethernet cable) service is running.

Screenshot 2023-11-20 at 5.10.23 PM

I am at a loss on how to resolve this, and am almost at the point of just returning these to try something else.

You connect your Mac with the GL-MT3000 Beryl AX directly. Do not connect to your router (it doesn’t come into play in this).

My Mac is directly connected to the Beryl AX (not my ATT unit)

I wasn’t sure if you still had a connection to your AX88179A going off the comment and the screenshot.

Completely ignore your ATT router initially.

Have you ever been able to connect to the unit at either WiFi or ethernet?

If you can ethernet connect directly to your Beryl. Don’t forget you need to have DHCP set on your client machine for normal connection at

To reset , you need to have your unit loaded up initially, so plug it in and then just leave for 5 minutes. Then hold down the reset button, it’ll flash faster fo 5 flashes, faster for 5 flashes and then faster again at which time release the reset button. You should then be able to connect (hopefully) at

To uboot, you need to disconnect the power, hold down the reset button and insert the power (holding down the reset button) , the led will flash 5 times and then go solid, at which time you release the reset button. You then have to have you client set to 192.168.1.x to be able to connect.

Sound like maybe it’s just a timing/procedure issue…

Once you get this all sorted then you can move to the next stage of connecting to your ATT router.

1 Like

Ok, I’m not exactly sure why the factory reset started working, but now I’m able to connect to the web UI at

My current problem however is that when I connect my GL-MT3000 to my ATT Gateway unit, it’s not detecting that an ethernet cable is inserted, and saying “No cable detected in WAN port. Please use an ethernet cable.”

I have rebooted my router using the web UI, but even after it reboots I still see the same message. Any thoughts on why my router isn’t detecting the inserted ethernet cable?

I’ve also updated my firmware to the latest version (v4.4.6) but that’s not solving the issue either