USB Kingston Dongle

If I plug an USB Kingston Dongle in the USB port, I can see it using “lsusb”, but it is not mounted.
The dongle is formatted in VFAT, but I can’t mount for it.

“lsusb” shows this :

Bus 001 Device 016: ID 13fe:1f00 Kingston Technology Company Inc. DataTraveler 2.0 4GB Flash Drive / Patriot Xporter 32GB (PEF32GUSB) Flash Drive

“dmesg” shows this :

[ 1054.250000] usb-storage 1-1.1:1.0: USB Mass Storage device detected
[ 1054.250000] scsi111 : usb-storage 1-1.1:1.0
[ 1055.260000] scsi 111:0:0:0: Direct-Access Kingston DataTraveler 2.0 PMAP PQ: 0 ANSI: 0 CCS
[ 1055.420000] usb 1-1.1: USB disconnect, device number 115
[ 1055.440000] sd 111:0:0:0: [sda] READ CAPACITY failed
[ 1055.440000] sd 111:0:0:0: [sda]
[ 1055.440000] Result: hostbyte=0x01 driverbyte=0x00
[ 1055.450000] sd 111:0:0:0: [sda] Sense not available.
[ 1055.460000] sd 111:0:0:0: [sda] Write Protect is off
[ 1055.460000] sd 111:0:0:0: [sda] Mode Sense: 75 73 62 6d
[ 1055.460000] sd 111:0:0:0: [sda] Incomplete mode parameter data
[ 1055.460000] sd 111:0:0:0: [sda] Assuming drive cache: write through
[ 1055.480000] sd 111:0:0:0: [sda] Attached SCSI removable disk
[ 1055.740000] usb 1-1.1: new high-speed USB device number 116 using ehci-platform
[ 1055.890000] usb-storage 1-1.1:1.0: USB Mass Storage device detected
[ 1055.890000] scsi112 : usb-storage 1-1.1:1.0

On my Unbuntu 12.04 machine, it is mounting perfectly.
I’ve tried another one, working also on my Ubuntu, but it doesn’t even shows up in “lsusb”.

can you try to see if there is any storage devices listed by list the files in /dev/

ls /dev/

If you see devices like /dev/sda1, it means the device is recognised. Then you mean do a manual mount to see if it is successful.

mkdir /mnt/sda1
mount -t vfat /dev/sda1 /mnt/sda1

I guess that the auto mount scripts are failed due to some parameters problems.

Unfortunately, the /dev/sd? doesn’t show up for the USB Kingston.

I’ve noticed another strange thing probably related : I’ve plugged an SDCard USB Reader with the SDCard which was working early thru the SDCard slot.
When this reader is hot-plugged, it been shown in “lsusb”, and “dmesg” says that it is now available as /dev/sdb, but when I try to mount it, the “mount” fails.

Bus 001 Device 107: ID 14cd:121c Super Top microSD card reader

[ 6317.090000] usb 1-1.1: new high-speed USB device number 107 using ehci-platform
[ 6317.230000] usb-storage 1-1.1:1.0: USB Mass Storage device detected
[ 6317.230000] scsi66 : usb-storage 1-1.1:1.0
[ 6318.240000] scsi 66:0:0:0: Direct-Access USB Mass Storage Device PQ: 0 ANSI: 0 CCS
[ 6318.600000] usb 1-1.1: reset high-speed USB device number 107 using ehci-platform
[ 6318.760000] sd 66:0:0:0: [sdb] Attached SCSI removable disk

mount -t ext4 /dev/sdb /mnt/sdb
mount: mounting /dev/sdb on /mnt/sdb failed: No medium found

SDCard doesn’t support hot plug and play. You can reboot your device to see if there is there.
/dev/sdb is not a partition. The correct partition should be /dev/sdb1, with a number at the end. It seems that the system cannot find the correct partition.

From the log you posted at the first post, it seems to recognised the correct device. You USB device is 32G? Can you use a 4G or 8G one to try?

In tha case above, it was not SDCard inserted into the sdcard socket of dominio, but an SDCard inserted into an USB Reader.
Unfortunately, the /dev/sdb appear but without partition number and no other /dev/sdb? were present. It was a 4GB card.

anybody else have this problem? Unfortunately the USB disks I have works fine. Maybe because of filesystem? Vfat should works fine. NTFS and EXT works better.

In fact, I have more info on the topic :
On my second DominoDi free PCB, I’ve try to connect this Lexar SDCard reader directly to USB pins without using the USB tile.
It detect it propler according to dmesg, I was able to see /dev/sda1/, mount it, but as soon as I tried to do “ls” on it, the kernel start showing the directory listing and than hangs … :frowning:

not sure what is the problem. Need to find a 32G disk to try.