USB Tethering broken in IOS 14 (Fixed Nov 26 2020)

Yes, not even just routers by the look of it.

See here. DDWRT, Fritzbox, Linux, Synology, Dell… :frowning:

Have you made any progress?

I‘m not able to get it working in any way. SUPER annoying!

1 Like

Any progress?? I have useless router now

1 Like

Hi

Just bought the router last month for tethering purposes. Do you have any idea when there will be an update to resolve the IOS problem?

Thanks

As @limbot already said, this is affecting not just GL routers, other large brands as well.

You guys can follow along here:

@radishman Has been working with them to try to fix it.

Here are Apple users complaining on their official forums, no official reply:

https://discussions.apple.com/thread/251841768

1 Like

I spoke to upper level support at Apple about a week ago…they said they’re not going to do anything about it. At least that’s what they told me. If someone doesn’t do something about it soon I’m switching to a Samsung

Not an optimum solution and it won’t work for everyone, but I am using my hotspot to drive internet access to my entire network in a very rural location. My workaround is to plug my iPhone into my Mac using USB and then bridge to share the internet to my ethernet port on the Mac. Finally, I connect the Mac’s ethernet cable to the WAN port of the router and it supplies the entire network from there.

Hope this helps at least a few. Bridging can be accessed on the Mac via "System Preferences → Sharing → Internet Sharing and sharing from iPhone USB to Ethernet. It is probably possible to do this with Windows as well, but I didn’t look into it since I was able to do it with the Mac easily.

I’m not sure that this is the same problem that we are experiencing. I turned that feature off on my iPhone in the settings and am still unable to get the iPhone to connect to the router.

Thanks, I’d forgotten about network bridging. Works great on my SP with Win10. :slight_smile:

2 Likes

I’m not sure it’s the same problem we’re experiencing either…
I can connect to the router but no internet

2 Likes

According to the 9to5mac’s article. Will disabling the MAC address randomization fix the tethering problem in iOS 14 and firmware 3.104?

1 Like

No, I tried this already. This is not fixing the problem.

1 Like

Still no progress with a new firmware?

1 Like

I updated to iOS 14.1 - no change, still not working.

1 Like

Please keep an eye on the links i posted here:

This issue is in the underlying library that OpenWRT (and GL) firmwares use for tethering.

You guys should probably complain with Apple, as they released a breaking change for many users without any warning so that devs might have a chance to fix it beforehand. As already stated, all brands and hardware seem to be affected, not just OpenWRT based routers.

As Apple have also not released any specs to what has changed, you can see in the links above some generous people are donating their time to reverse engineer the changes and make the fixes.

2 Likes

So Im having the same problem…I wanted to check and see if i could tether my phone directly to my mac-air…as soon as i did i got a request to install a program from apple, after installation everything worked on my mac-air. Just wondering but maybe apple is setting up tethering to only the computers that can communicate with the software on the iphone and since the router doesn’t have this software or maybe its hardware the software is looking for. just a thought…

1 Like

Same USB tethering problem here on my GL. But note that the problem also exists on ANY Linux computer.

Apple has already stated that they won’t provide a fix, and it is up to manufacturers to update their systems. But Apple does not state what to update or how. The problem impacts the ENTIRE Linux ecosystem.

Bottom line is that Apple sucks hard. But hopefully GL or others can come up with a way to implement a fix.