Use as bridge LAN<->WAN<->WIRELESS

I have a room with a pc. I need to connect the eth.cable of PC to the WAN port of the router and reconnect the PC to the LAN port (that act as a bridge) and finally uses the wireless.
The PC has a static IP. The WAN has access to internet.
The wireless correctly uses a different net.
Unfortunatelly the LAN port assumes the address of the WLAN net instead of the WAN.
I tried to change the bridge configuration but looks like it go back to previous configuration.
I would also like avoid to use a static ip of my lan for WAN and LAN ports.
Any help appreciated.

Sorry, I don’t quite understand, your PC needs to connect WAN port and LAN port at the same time? Or, what is your purpose for connecting to the WAN port first?

The router must function as a switch on the ethernet ports and allow to the main wifi network to see the local network and surf the internet and the guest wifi only to surf the internet.

May be this can explain better:


internet—>switch------|room-wall|—eth.cable—>PC (no wifi)


internet—>switch------|room-wall|—cable—>(wan) [GL-MT300N-V2] (lan)----eth.cable—>PC + wifi

The actual lan has no DHCP and is a 192.168.195.x with gateway .1 and dns .49.
The PC has a static IP and must be kept.
The default router main wifi 192.168.8.x with internet access and gateway on lan is ok.
The default router guest wifi 192.168.9.x with internet access only is ok too.

I changed the default WAN from dhcp to static ip
Everything work but the PC doesn’t see the lan (because the LAN port assumes ip 192.168.8.??)
If I change WAN to LAN, the PC see the lan but the wifi stop to work. I see the SSID but cannot connect.

Are you trying to manually configure bridge mode? Do you use the bridge function that comes with the route?

I start from factory settings.
I change the Cable config from DHCP to static ip of my local network.
After that the main wifi NAT to my local network. The guest is separated. And this is perfect.
Now I attach a PC to the lan port of the MT300N but this doesn’t see my local network. It takes ip of main wifi.