Using ATX1800 with QUECTEL EM160R-GL

Checked again. 4.1.0 release 7 support this modem.

Also from your log, the modem is supported.

Can you check if you have all the ttyUSB device in /dev/?

Also did you change anything on the modem?

I wrote in my initial post: “the modem was detected (info in the log), but neither the gl-inet GUI detects it nor a new interface has been created.”

I can make it work if I manually create the proper interface and assign to it the correct device (it will be /dev/cdc-wdm0 in case of QMI or /dev/ttyUSB2 or /dev/USB3 in case of UTMS) but this not what users have to do.

Can you please provide the rest of information I requested (d, e) ?


Can you provide the ID of the device? It can be viewed through ‘lsusb’.

root@GL-AXT1800:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux 4.4.60 xhci-hcd xHCI Host Controller
Bus 002 Device 002: ID 2c7c:0620 Quectel EM160R-GL
Bus 002 Device 001: ID 1d6b:0003 Linux 4.4.60 xhci-hcd xHCI Host Controller

The connection is set, I can control the modem via luci but gl GUI does not show the modem info, it says " NO MODEM DEVICE FOUND".

This is the 4th time when I am trying to get the answer to a very simple question - WHAT IS THE NAME OF WWAN INTERFACE THAT HAS TO BE CREATED BY GL AFTER THE MODEM HAS BEEN DETECTED BY GL SOFT?


As long as you have ttyUSBx and cdc-wdm0 the modem should be displayed.

You can bind to the cloud platform to share with me, I will check the specific situation remotely.

My account is ‘zhangli’.

I re-uploaded the latest firmware, reset the settings. I bound the device to a new account opened on goodcloud and shared it with your account. Right now the router works in repeater mode, the modem is attached and detected (the records in the log) but cannot be seen in GL GUI.

But if you jump straight to

you will see that the modem is alive and connected:

The name of APN to use: h2g2, no authentication.

Hi i7bar:

Thank you very much for your feedback.

Maybe this modem or sim card is special,So some information about the sim card cannot be obtained. As a result, the web page is not displayed.
We will accommodate this special case.

I temporarily updated a few packages. It should now display normally.

However, since mcc/mnc cannot be obtained, you need to fill in the APN by yourself.

Thanks for the troubleshooting. Yes, now GL.Inet GUI properly detects the modem, so at least this problem has been fixed.

Please two more things to consider:
a) it would be extremely useful if the edit field “AT Command” could preserve the list of the previously entered AT commands(at least during the current session);
b) it would be even better if the user could add this own modem specific AT commands to the dropdown list stored in “Shortcut” field since the same commands will be entered again and again;

The reason why entering AT modem specific commands is important is pretty simple - nowadays just connecting the modem to a cell tower is NOT ENOUGH. In case of EM160R and other modern modems users will want to choose the band / group of bands (by specifying what bands to connect), enable certain types of aggregations (by specifying what bands to include in aggregation), lock the modem to a certain cell and so on. All these steps are essential in getting a robust and fast cellular connection, contrarily to autoamtic connect the the most utilized band in the area and therefore being providing the lowest speed and highest latency.

I am resetting the router and will wait for the next firmware that it supposed to provide all users of EM160R-GL LTE modem with the aforementioned fix.

PS: I asked the question, did not get any answer and therefore will answer myself - the name of WWAN interface which is used by GL-Inet GUI and mwan3 is ‘modem-2-1’ where 2-1 is the

qmi_wwan 2-1:1.4: cdc-wdm0: USB WDM device
Thu Dec 15 20:20:49 2022 kernel: [ 14.178317] qmi_wwan 2-1:1.4: QuectelEC25&EC21&EG91&EG95&EG06&EP06&EM06&BG96&AG35 work on RawIP mode


‘2-1’ is the USB-bus.

As for other suggestions, will consider them.


What packages did you update? I’m trying to get the EM160R-Gl working a Beryl. Thanks.

I now have a Slate Plus connected to an EM160R-GL using firmware 4.2.0 Beta 2, and there’s still nothing showing up in the GUI. Firmware 4.1.2 also didn’t work.

Here’s a snippet from the kernel log:

[  175.041436] usb 2-1: new SuperSpeed Gen 1 USB device number 2 using xhci-hcd
[  175.232679] option 2-1:1.0: GSM modem (1-port) converter detected
[  175.233200] usb 2-1: GSM modem (1-port) converter now attached to ttyUSB0
[  175.239009] option 2-1:1.1: GSM modem (1-port) converter detected
[  175.245084] usb 2-1: GSM modem (1-port) converter now attached to ttyUSB1
[  175.251649] option 2-1:1.2: GSM modem (1-port) converter detected
[  175.257943] usb 2-1: GSM modem (1-port) converter now attached to ttyUSB2
[  175.264658] option 2-1:1.3: GSM modem (1-port) converter detected
[  175.270709] usb 2-1: GSM modem (1-port) converter now attached to ttyUSB3
[  175.296134] qmi_wwan 2-1:1.4: cdc-wdm0: USB WDM device
[  175.296430] qmi_wwan 2-1:1.4: QuectelEC25&EC21&EG91&EG95&EG06&EP06&EM06&BG96&AG35 work on RawIP mode
[  175.301933] qmi_wwan 2-1:1.4 wwan0: register 'qmi_wwan' at, WWAN/QMI device, 9e:2d:e0:ee:2f:XX

Here’s my modem details from ATI command:

Revision: EM160RGLAUR02A09M4G

And the usbnet query:

+QCFG: "usbnet",0


Things I’ve tried:

  1. Plugged in the USB and rebooted the router.
  2. Rebooted the router without USB plugged in, and then plugged in after 5 minutes.
  3. Changes the glconfig setting per this post. I’ve tried both ‘2-1’ and ‘1-1’ (rebooting each time).

I wish you would share what packages you updated for i7bar.

I wonder what you see if you jump to:

Can you show the screenshot?

PS: One more thing - can you show the list of available interfaces?
You can download the above firmware to use.

Thanks for the reply. I managed to get it working perfectly out of the box using Rooter by modems and men with my old beryl. I’ve already returned the Slate back to amazon because I just couldn’t get it to work for the life of me, despite installing various packages.