Using port 83 (to upgrade firmware) never works

Just received an MT300N and am trying to figure out the fastest way possible of upgrading them with our own openwrt firmware.

Typically, I have to set up a wireless laptop and connect to the router then upgrade the firmware. It would be much faster if I could do it using the web interface with the DHCP IP that is pulled to the WAN port when first connecting the unit.

I connect to port 83, it asks me to set a password which I do, then it immediately says the password is wrong, mismatched.
I then fire up a new tab and re-connect to port 83 and this time get a login screen.
I enter the password I used and the 16 digit S/N found on the device but always get ‘Input is wrong’.

I’ve tried this on several of these devices but it never works. It would be much faster if I could reach the device using port 83, then upgrade it’s firmware with mine and be done in a few minutes.


You have a cable, why not directly connect to the LAN port and connect ?

Because the LAN port tries to pick up a DHCP IP, gets one, then goes offline. It never comes up with IP, only the wireless interface does as I recall. However, the WAN port does pick up a DCHP IP which I can reach as I said, can enter the new password but then it always tells me it is wrong.

It seems I am able to reach the device using the DHCP IP but that there is an issue on the device with never allowing access at this point. This happened with others because I keep trying to simplify the upgrade method with these devices.

As you can see, I can reach the device;

Nmap scan report for
Host is up (0.00048s latency).
Not shown: 999 closed ports
83/tcp open mit-ml-dev
MAC Address: E4:95:6E:40:E0:03 (Unknown)

I then browse to that IP and am asked to login using the password and S/N. However, just like all the others I’ve tried, entering the new password I just created and the S/N lead only to an error, no login.



have you modified the firmware? What LAN don’t come with a static IP?

I explained the entire process I’ve done above :).

I have not gotten to any point of modifying anything, I am simply wanting to gain access via hardware interface rather than the wireless interface in order to upgrade it with our own firmware.

As explained above, I can reach the device on the WAN port (DHCP IP) but it never responds to entering the new password I created and using the S/N.
It is doing the same thing as some previous versions always did, forcing us to use a wireless laptop connection to upgrade the devices which is a much longer process for us.

See, look at the image. It is still running gl.inet firmware. I am trying to avoid having to use a wireless method because then it takes long as we have to copy the image to a usb stick, move it to the laptop, etc etc. Being able to log in using the hardware nic would make it much faster.

As you can see, I have access via port 83, I have set up a password and I am now trying to log in but it never allows log in, always saying input is wrong.

Never mind, I found a simple way of doing it by adding a wireless usb device to the PC. Now it has access to both networks that it needs.

Problem solved.