VPN being recognized when running on the router

So, I run PIA through my 1300M and it’s been working fine until tonight when Hulu and Netflix decided they would start detecting that I was using a proxy.
I tried every config file and no luck. But then I switched to my ISP router and ran my PIA client through windows and Hulu and Netflix work fine. So clearly it’s something with the connection through the router. I need the router working so I can use my ps4 and TV to watch things, I can’t sit at my computer all the time.
Any help would be great.

I think I may have figured it out. Perhaps the port is being blocked.

Edit: no I changed to a tcp port in the .ovpn file and same result, yet I have no problem using my VPN with the openVPN client and my vpn’s own gui client software. So it’s definitely something the streaming services are picking up off the gl.inet router.

I wouldn’t conclude that it’s the GL router’s fault too quickly. For example, USA Server 1 is probably a different IP on the Windows client to USA Server 1 using ovpn files - this is my experience with other providers, anyway.

PS. PIA isn’t the greatest or most trustworthy - you can do better.

I am aware that pia is not the best, but I’m paid up until October, so I’m trying to make it work.
I’m using the same config file for openVPN gui where it’s working just fine, and the router. I will ask pia support if they have any idea as to what the issue might be.

Maybe it’s DNS / DNS leaking - what settings have you set for these in the router?

DNS server 1
DNS server 2
I am not overriding all clients DNS settings.
I ran dnsleaktest.com and for the first time I actually just caught a leak.
So I need to fix that it seems

Did you fix that? Pls report.

I used openDNS and it did not work. Although there were no DNS leaks, nor any IP leaks

What firmware version? > please upgrade
Try DNS over TLS from Cloudflare (in V3 firmware)

Currently on v2.272. I don’t see a v3 firmware package in the b1300/testing folder.

Yes, testing directory is empty but there should be 3.012 file there according to :

However, you could try this one:

Ok, v3 working overall, but it must be something about the pia config files then, even though it’ll work with the same file on the openvpn gui.
I guess all that’s left is to get another VPN. I just don’t have the money to spend right now, what a pain.