VPN not starting... but it was working great for weeks

I do not know why. Might be related to a powercut a few days ago.

Anyway VPN will not connect… it stays at “please wait…”.

If I look in the LuCi (Advance Settings > System > Startup (Initscripts)…

startvpn is enabled, but openvpn is disabled.

Is this correct? If I enable it and reboot, it goes back to disabled.

I think I had this problem before, but it was >6 weeks and I have forgot.

GL-AR150 Firmware v2.20 ExpressVPN


Many thanks for helps

Update: I am reading further in forum.

Is it right that you replace “openvpn” with your own version “startvpn”, and only startvpn should be enabled?

So it is OK for me to have “openvpn” disabled all the time?

If so then I have some other error causing “Please Wait…”…?

Solved it. Spelling mistake in the ovpn file. Sorry.

glad that you solved it. Yes we disabled /etc/init.d/openvpn because it will read all the configures from UCI, which requires you to configure in details. This is so difficult for common users and this is why we used our own version.

I’ve flashed my AR150 with 2.25 firmware, performed a factory reset and then configured OpenVPN. But OpenVPN didn’t start automatically after a reboot for an unknown reason. Looking at startvpn code, I saw it checks “glconfig.openvpn.enable” value but there was no “openvpn” section in the glconfig so the “uci set glconfig.openvpn.enable=1” command returned an error. So I had to add “openvpn” service section to glconfig manually.

Please check your config generation scripts.

I just check AR150 V2.25 does have glconfig.openvpn section.