Vpn Server Issue with AX-1800, wireguard server set up

I have set up Wireguard VPN server on AX1800, my home router is ATT router, set up the port forwarding there, also set up IP passthrough and added the macaddress of my router. I have tried chaning to UDP or TCP Or both only but still have issues. I am getting
Wed Sep 20 15:13:42 2023 daemon.notice netifd: Interface ‘wgserver’ is setting up now
Wed Sep 20 15:13:42 2023 daemon.notice netifd: Interface ‘wgserver’ is now up
Wed Sep 20 15:13:42 2023 daemon.notice netifd: Network device ‘wgserver’ link is up
Wed Sep 20 15:13:42 2023 kern.info kernel: [11551.747952] IPv6: ADDRCONF(NETDEV_UP): wgserver: link is not ready
Wed Sep 20 15:13:42 2023 user.notice mwan3[1035]: Execute ifup event on interface wgserver (wgserver)
Wed Sep 20 15:13:43 2023 user.notice mwan3[1035]: Starting tracker on interface wgserver (wgserver)
Wed Sep 20 15:13:45 2023 user.notice firewall: Reloading firewall due to ifup of wgserver (wgserver)

I don’t know what needs to be done, I spoke with ATT tech team and they said they have done everything to allow the firewall but still having an issue

First, pls upgrade to the latest stable firmware.

Second, as you are setting up a wireguard server, it may not show you any problem. The issue happens when you want to connect wireguard client to it. So you need to show more info:

  • how do you set up port forward, pls give screenshots
  • how do you connect wireguard server, pls show screenshots

As the images may contain your private info, I suggest that you send email to support at glinet.biz