VPN Server on MT300A Ext

Hi all,

I’m new in this forum and I’m here as I bought an MT300A ti use it as VPN Serve to bridge to ADSL modem.

Unfortunately I noticed that VPN server for this product is not available yet, anyone can suggest me how to install it in easy way? a sort of step procedure to do it?

I know that we might have performace issue but I would use the terver only to get connected to my intranet sporadically so shouldn’t be an issue

regards

 

 

The most important thing is to generate cert files. These needs a lot of CPU time. Sorry I don’t have a step by step guide for now. Hope someone else can help.

I think this is the best wiki article at OpenWrt for the purpose.

https://wiki.openwrt.org/doc/howto/openvpn-streamlined-server-setup

You should do a wiki search on OpenVPN and read some of the other article too.

Thanks for the answer!

Does it mean I can login on the device by using ssh connection? Do we have root credential on mt300a devics?

Thanks

 

I do not know those answers, but I suspect once the tunnel is up, and if you configure ssh properly, you can do what ever you can from “home”

Thanks, actually the question was:

to apply the procedure you suggested “https://wiki.openwrt.org/doc/howto/openvpn-streamlined-server-setup” I need to connect to mt300a via ssh, is that possible? has the mt300a the port 22 open? and which is the uid and pwd?

thanks

 

first step done the mt300a has port 22 enabled and the password for root is the one set through the GUI. Actually if anso from GUI advanced setting you have the same root account and administrator password.

next to go is to install the VPN Server but it looks that opk update does not work fine, says tha signature for the packages are not ok, any idea?

regards

@silvano, are you using v2.21? please update to v2.22 which is backed by full software repository. GL.iNet download center

We will officially release this once fully tested.

now using v2.22 same result:

root@GL-MT300A:/etc# opkg update

Downloading 404 Page not found - GL.iNet

wget: bad address ‘www.gl-inet.com

Downloading 404 Page not found - GL.iNet

wget: bad address ‘www.gl-inet.com

Signature check failed.

Remove wrong Signature file.

root@GL-MT300A:/etc# opkg install openvpn-openssl openvpn-easy-rsa

Package openvpn-openssl (2.3.6-5) installed in root is up to date.

Unknown package ‘openvpn-easy-rsa’.

Collected errors:

* opkg_install_cmd: Cannot install package openvpn-easy-rsa.

 

so I’m unable to install vpn server

any suggestion?

it looks that is unable to resolve the name www.gl-inet.com

root@GL-MT300A:/etc# ping www.gl-inet.com

ping: bad address ‘www.gl-inet.com

any one knows how to fix it? any configuration change we might need a dns sarver to specify somewhere

thanks

 

ok one step more. Added nameserver 8.8.8.8 in resolve.conf an now worked

:slight_smile:

now time to play with openvpn server configuration

 

Are you by any chance running the device behind another router?

If you go to Luci=>Network=> Diagnostics can you ping etc?

Probably worth explaining this config in detail

I bought an MT300A ti use it as VPN Serve to bridge to ADSL modem

yes for now I have it after the Modem/Router fron the provider. I configured the MT300A as simple router under the same subnet and now is working fine as such. I had to set the ip-gateway to the modem/router IP and added google nameserver in the resolve.conf.

when I see the vpn server working fine I’ll bridge it to the modem