WDS problem


#1

I have numerous GL-AR300M routers and need to cover a large area for multiple clients with them. I would prefer to use WDS but am having difficulty. I can not rely on the client router supporting WDS, so my plan is to have one GL-AR300M set up using WISP connected to the client’s router and then have the remaining routers set up using WDS.

All routers are at firmware version 2.27, which it reports as the latest available.

Here are the problems that I am seeing:

When I set up a router for WDS, it does not automatically change the AP settings to match as you would expect if it were acting as a bridge. I have to set these myself. Annoying, but I can work with it.

Bigger problem is that when I set up WDS and set an IP address, the router disconnects (which I expect) but it does not appear at the IP address that I defined. I have tried connecting to it wired and wirelessly. I also tried not setting an address and monitored the DHCP server to see if it got one from there. It did not. The result of all this is that WDS is not working at all on these routers.


#2

Firstly, try upgrading to this:
http://download.gl-inet.com.s3.amazonaws.com/firmware/ar300m/nand/testing/gl-ar300m-3.013-0128.tar