Which is the GIT right version for AR300M LEDE build repo?


Hi. what is actually the right build version on your Github to build an AR300M LEDE binary?


EDIT: OK I understand that the last release is: https://github.com/gl-inet/lede-17.01



Finaly I,ve been able to compile your LEDE 1701 for AR300M NAND target (from https://github.com/gl-inet/lede-17.01) with all my required packages without errors.

The generated files are:

12K dic 22 04:43 packages
29M dic 22 05:24 lede-ar71xx-nand-device-gl-ar300md-rootfs.tar.gz
4,2M dic 22 05:24 lede-ar71xx-nand-vmlinux.elf
4,2M dic 22 05:24 lede-ar71xx-nand-vmlinux.bin
1,4M dic 22 05:24 lede-ar71xx-nand-vmlinux.lzma
1,3M dic 22 05:24 lede-ar71xx-nand-uImage-lzma.bin
1,4M dic 22 05:24 lede-ar71xx-nand-vmlinux-lzma.elf
23M dic 22 05:24 lede-ar71xx-nand-root.squashfs
0 dic 22 05:24 lede-ar71xx-nand-device-gl-ar300md.manifest
13K dic 22 05:25 config.seed
885 dic 22 05:25 sha256sums

Look at the sizes. I understand that for creating an openwrt or lede update file i need to create a tar file with structure:

/sysupgrade-gl-ar300m/CONTROL (containing the text: BOARD=gl-ar300m)

/sysupgrade-gl-ar300m/kernel (renamed copy of: lede-ar71xx-nand-uImage-lzma.bin)

/sysupgrade-gl-ar300m/root (renamed copy of: lede-ar71xx-nand-root.squashfs)

But which is the img file to update nand from uboot? Is it generated?

I expected to get a file type u-boot legacy uImage, MIPS OpenWrt Linux-3.18.27, Linux/MIPS, OS Kernel Image (lzma) with about 24MB or similar but


is just 1.3 MB

What have I lost?



Seems the firmware is not generated. I will have a look.


@ <span style=“color: #222222; font-family: source_sans_proregular, ‘Helvetica Neue’, Arial, Helvetica, Geneva, sans-serif; font-weight: bold;”>yadox</span>


We have fixed this bug, you can pull the new code and rebuild again.

git pull

rm -fr tmp/

make defconfig

make -j5


Thank you. It is really working. I could now successfully make my own build for AR300M.

I do not recommend to use make -j5 or -jn. I allways get problems building lede with multithreads. I only get a clean compilation with -j1.



Hi again

Now I have the images in the right format.

But I when I get into u-boot HTML flash procedure, I only get one option and not two like in your wiki (Flash NAND image and flash NOR image).

And after selecting my brand new image (20MB) in ubi format, I got a html reset (attached image).

I tried the same procedure using Gli Tor NAND image and it works.

I think the error is maybe related with the size of the image(maybe there’s a file size limit in ubi HTML flash utility).

Can you please help me?



The Uboot UI has to write the image to ram first I think then copies to flash and as your image is 20MB could be causing the problem.

The full GL-i image is only 4MB is it not?

20MB does seem very large and I cannot imagine what you have in it :slight_smile:

Why not try putting the clean image on first, then use sysupgrade utility to reflash. LEDE/OpenWrt will then have over 120MB of free /tmp ramdisk to work with.

Worth a try anyway…



Yes. At the end is what I did. I used your v1 image and them from your CGI web panel, I wrote down the 25MB image and it worked! Need two steps to write the flash, but it worked. Can you please tell me what commands are you calling from the firmware upgrade utility inside of the CGI to do the upgrade procedure to NAND?

It’s not very clear how can I flash the NAND and the NOR images.

Does luci permit to upgrade both or only one? What image is necessary for luci to work?

The u-boot doesn’t work as expected.