Wireguard client and VPN policies not working?


I have a AR750S with Firmware 3.104.
I want to use Wireguard Client only to connect to my local home network and not for full internet access.
However this does not seem to work. As soon as I activate the wireguard client I loose access to the rest of the internet.
I thought the VPN policies would solve this problem but they don’t. Is there a known bug with the vpn policies?
With or without VPN policies activated it seems that starting the wireguard client sets the default route through the tunnel.
In the routing table I see the entries and set to wg0.
Is there a way to prevent the wireguard client from setting the default route through the tunnel?
(my allowed ips setting ist not but only set to my internal network)

VPN policies, from the feedback, should work pretty stable.

Does your wireguard work without setting policies.

You should give your network diagram so that we can check in more details.

Yes wireguard works without setting policies, but then all traffic goes through the tunnel. Thats what I don’t want. I only want to route my private network at home trough the wireguard tunnel.
And that’s what I thought I could use VPN policies for.
But as I wrote in my previous post, the wireguard tunnel is always set as the default route, with or without the policies activated.
This is done in the wireguard start script.
But I don’t want the default route to change when activating wireguard or it needs to be reverted when setting the corresponding VPN policy.

Wireguard will change the route, one way or the other.

So maybe you can just let us know what is your “local network”, e.g. IP and subnet. How did you set up the vpn policy?

The policy should work for your purpose.