Wireguard Client DNS bug

Hy! I noticed something wierd on my MT300N-V2, running the latest firware, when I use it as a wireguard client.

The Ipv4 address I set in the DNS field overwrites the Ip4 address in the IP address field when I try to connect.

The router establishes a connection to the wireguard server, but the address displayed on the MT wireguard page as the client address is, in fact, the DNS address. Of couse, no real traffic can flow beside the key exchange over the interface.

Example (inaccurate for expediency) on the MT300N (Serving addresses on the network and with a WAN gateway IP on

Settings before I attempt to connect:

Ip Address =
DNS = (I have unbound serving DNS over works great for all other clients)

After the connection:

Ip Address =

It does the same with public dns addresses like

Settings before connection:

Ip Address =

Settings after connection

Ip Address =

It doesn’t seem to affect ipv6 addresses though…

I think it might be a bug, it happens every and any time.


I tested on AR750s 3.212 beta3 and I don’t have the problem.

Pls use the right format. Here is mine.

The config should not be modified during connection. It can only be modified during config upload.

Hy! I’m on stable, not on beta.

My format is correct, since it looks exactly like yours once its translated to my real network addresses (plus I use also Ipv6).

The config should not be modified during connection. It can only be modified during config upload.

I’m with you, but tell it to the router! I edit the config, apply, connect and the address assigned it’s the DNS address, not the IP.

Check it out:

And when I disconnect and go back to the management tab, this is what I find:


I went through the Custum DNS tab for the router and disabled all options, just to be sure, but nothing changed.

Sorry for the many replies, I can’t post more than one media item per reply as a new user :smiling_face:

Can you check 3.212 beta3? GL.iNet download center

I could set up a server and check the same but it needs time.

Sure, I’ll test it right now!

I installed 3.212 Beta 3.

Same problem, the IP address shown on the Status tab is the DNS address.

My wg command on the remote wireguard server shows that the initial connection takes place (the key exchange probably) but then no traffic flows. The last handshake counter increases but transfers remain in the 2kb range.

I verified a few times and there is a difference from 3.211: once I disconnect and go back to check on the Management tab the IP field it’s not overwritten with the DNS address. But, functionally, it makes no difference.

I tested my own server.

I don’t have IPV6

The IP didn’t change to DNS

I’ll try without Ipv6, let’s see

Ok, without IPv6 addresses in the IP and DNS fields the connection works as intended. I get the IPv4 I should get and the DNS is served from the server, I can access the internet and it works.

IPv4+IPv6 doesn’t work.

I tried to get only IPv6 working, no dice. When I set my IPv6 address and my DNS address, I cannot apply the config. The GUI tells me the IPs are invalid.

Should we say that we should stick to IPv4 only for the time being?

yes please. Will investigate the IPV6 problem.

Great! I’ll revert to stable and do a sanity check with Ipv4 only first.

Ok, on 3.211 stable wireguard with only Ipv4 addresses works as intended. I’m going to mark the thread solved, thanks for the chat @alzhao!