Wireguard disconnecting

Hello,

I have the Beryl AX router. I have one set up as the server and another one that I use while traveling. WireGuard has been working for me for a while now and then all of a sudden started disconnecting. The one I use as a server is not recognizing the ethernet cable coming from the router. And the second router was not connecting to the server. I tried reconfiguring it, and I’m receiving this log.

Log
Mon Apr 8 02:31:44 2024 daemon.notice netifd: Network device ‘wgserver’ link is down
Mon Apr 8 02:31:45 2024 user.notice firewall: Reloading firewall due to ifdown of wgserver ()
Mon Apr 8 02:31:45 2024 daemon.notice netifd: Interface ‘wgserver’ is now down
Mon Apr 8 02:31:51 2024 daemon.notice netifd: Interface ‘wgserver’ is setting up now
Mon Apr 8 02:31:51 2024 daemon.notice netifd: Interface ‘wgserver’ is now up
Mon Apr 8 02:31:51 2024 daemon.notice netifd: Network device ‘wgserver’ link is up
Mon Apr 8 02:31:51 2024 user.notice firewall: Reloading firewall due to ifup of wgserver (wgserver)
Mon Apr 8 02:38:23 2024 daemon.notice netifd: Network device ‘wgserver’ link is down
Mon Apr 8 02:38:23 2024 user.notice firewall: Reloading firewall due to ifdown of wgserver ()
Mon Apr 8 02:38:23 2024 daemon.notice netifd: Interface ‘wgserver’ is now down
Mon Apr 8 02:38:28 2024 daemon.notice netifd: Interface ‘wgserver’ is setting up now
Mon Apr 8 02:38:29 2024 daemon.notice netifd: Interface ‘wgserver’ is now up
Mon Apr 8 02:38:29 2024 daemon.notice netifd: Network device ‘wgserver’ link is up
Mon Apr 8 02:38:29 2024 user.notice firewall: Reloading firewall due to ifup of wgserver (wgserver)

Then on the receiving end im receiving this log:

NET] DNS64: mapped 72.219.191.83 to itself.
2024-04-08 02:48:49.401
[NET] peer(Eydy…EMWo) - UAPI: Updating endpoint
2024-04-08 02:48:49.402
[NET] Routine: receive incoming v4 - stopped
2024-04-08 02:48:49.402
[NET] Routine: receive incoming v6 - stopped
2024-04-08 02:48:49.402
[NET] UDP bind has been updated
2024-04-08 02:48:49.402
[NET] Routine: receive incoming v4 - started
2024-04-08 02:48:49.402
[NET] Routine: receive incoming v6 - started
2024-04-08 02:48:51.924
[NET] Network change detected with satisfied route and interface order [en0, utun3, pdp_ip0]
2024-04-08 02:48:51.926
[NET] DNS64: mapped 72.219.191.83 to itself.
2024-04-08 02:48:51.927
[NET] peer(Eydy…EMWo) - UAPI: Updating endpoint
2024-04-08 02:48:51.927
[NET] Routine: receive incoming v4 - stopped
2024-04-08 02:48:51.927
[NET] Routine: receive incoming v6 - stopped
2024-04-08 02:48:51.928
[NET] UDP bind has been updated
2024-04-08 02:48:51.928
[NET] Routine: receive incoming v4 - started
2024-04-08 02:48:51.928
[NET] Routine: receive incoming v6 - started
2024-04-08 02:48:54.510
[NET] peer(Eydy…EMWo) - Sending handshake

I was thinking that it was because I was on the same network, but I switched to the mobile network and it still won’t connect. And I have a work trip on Saturday and I need this to be working so any help will be appreciated. My previous set up was that the Internet would go from the modem into my router with the server and then into a switch and then into my other routers. But as of now, I can only access the Internet via wifi without wireguard active.