WireGuard, Fritzbox 7590ax, E3372h-320, GL-MT3000

Hallo, I have a Fritzbox 7590ax with a WireGuard server. The VPN connection works perfect from abroad with my Android phone and Windows PC.

Now, I want my GL-MT3000, which is located abroad, to connect as a client to the Fritzbox 7590ax ( in Germany. The GL-MT3000 ( is either connected as a Wi-Fi repeater or (MultiWAN) via the Huawei E3372h-320 with the internet. I’ve been trying this for a week, but it’s not working. I’ve already experimented with many configurations, and I even had a connection once. My DynDNS is working well; do I need to open any ports, perhaps? Unfortunately, I’m not very tech-savvy.

MFG sandokanismo

After a long search I found the right config

Address =
ListenPort = 62687
DNS =,
MTU = 1420

AllowedIPs =,
Endpoint = XXXXXXXXXXXXX.myfritz.net:54254
PersistentKeepalive = 25
PublicKey = DWCiwpmIJzuMEmKSQ+9m7G0O4EZgVciiX8xjcrm7rTY=


Hallo, I spoke too soon :face_exhaling:

The above config only works when the GL.iNet WireGuard client accesses the internet via Wi-Fi. As soon as I connect a USB Stick, I can no longer open any web pages. I have little knowledge, can someone PLEASE help me with what needs to be changed.

Gl.iNet MT3000: Fallback Multi-WAN 1) WiFi or 2) LTE
E3372h-320 HiLink:

LG sandokanismo

Can you disable wireguard and only use the LTE to access Internet? This is the first step.