Wireguard (Mullvad) not connecting after Update 3.025 (SLATE GL-AR750s)

After updating to firmware v.3.025, SLATE GL-AR750s stopped connecting to Mullvad-Wireguard.
All connections time-out.

  • I updated from v.3.022 to v.3.025
  • Without “keep Settings”
  • I entered Mullvad-Usernumber by hand
  • All Mullvad (Wireguard) config-files were accepted
  • After hitting the “Connect”-button, nothing happens, all connections just time-out

To check if it was a network-issue, I installed openvpn-Configs (NordVPN), and those connections work just fine.

With version v.3.022 on my SLATE, Mullvad-Wireguard was working for allmost a year now, after the update it’s broken?

Any help is appreciated :slight_smile:

Can it work before updating firmware? Would it caused by your account is expired?

It worked perfectly before (with firmware v3.022).
Mullvad-account is not expired.

Had you tried it on your PC? You can use WireGuard on PC with TunSafe.

I cannot connect to mullvad server either. Even using their windows app. Seems that this is they server problems. I will ask their tech support.

1 Like

I found the problem.


Key limit is exceeded. I have to login Mullvad and remove all my old keys. Then I need to add Mullvad again and it works now.

1 Like

@ alzhao
Great catch! That was exactly the problem! Thank you!

The point is: Each time you reset/upgrade your (gl.iNet)Router, and re-install Wireguard/Mullvad, the Router requests a new “Mullvad-WireGuard key”.
I have 3 routers, and upgraded all their firmwares, so I ran out of keys (3old ones & 3 new ones … makes 6 keys … but only 4 keys are available with Mullvad).

please mark the issue/post as solved.

Thanks everyone for the fast help! Great as always :slight_smile:

Understood the mullvad problem and seeking for a solution.