WireGuard VPN menu items disappeared?


#1

I have a GL-AR750S running the 3.009 firmware. I updated the gl-wg and gl-wg-server packages after seeing a post suggesting that doing so might fix a problem setting up AzireVPN, but now the WireGuard menu items in the web UI have disappeared. What can I do to get them back?


#2

Did you try to clear browser’s cache? You can try and see if it works.


#3

I cleared the cache and now the OpenVPN Client is gone, too (I only have OpenVPN Server under VPN in the menu). I can still get to the OpenVPN Client page by manually editing the URL to http://192.168.8.1/index#/vpnclient… which also works for getting to the WireGuard Client page at http://192.168.8.1/index#/wgclient, so it’s really just an issue of the menu.

… or maybe not. Trying to save a config for either Azire or Mullvad, I get the same “Warning: The API is unavailable!” popup.


#4

maybe you can just try the newest 3.013 firmware in testing folder.


#5

With the 3.013 firmware, the menu items are back and I was able to set up and use Mullvad. (My download speeds are like 8x what I was seeing on OpenVPN!)

I tried setting up Azire, and it said it succeeded, but the WireGuard Client page didn’t change from the empty state.