X3000 Spitz wireguard client issue on sim2 above firmware 4.3.0

Any firmware later than 4.3.0 wireguard client will not stay connected to sim2 (Tmobile). Constantly connects/disconnects cycle repeats non-stop. Same behavior on all builds I have tried from 5-12 thru 6-8. Switch back to sim1 (att) and wireguard client connects right away and stays connected. Multiple reboots and factory resets have no effect. I had to go back to 4.3.0 in order for wireguard client to work on sim2.

It has nothing to do with wireguard! It is a firmware issue with SIMs switching.

You can read all over the forum for the same exact issue.

I have no problem switching sims. As I stated in the previous post, the problem only appears when trying to use the VPN. Sim2 works fine without VPN.

Hi, to be honest, I had the same VPN issue with this firmware, and using only one SIM slot (the 1 if I remember well).
I immediately rollback the update, I need the router stable for my VPN work.
I hope that they will fix this VPN issue soon, anyway, I’m not going to update the firmware until I will be 100% sure that the VPN will work without interruption.

Strange indeed. I have the same problem with SIM slots, but not with Wireguard… I am Italian like you (at least judging by your name :wink:) and I’ve tested basically all operators… I only have problems with some of them (mostly Windtre, Very etc.) but all is fine with others (Iliad, Vodafone, Postemobile…).

Hi, I’m not Italian, even if the name seems Italian!
I tried again with the new firmware, and same issue, it’s strange because without the VPN everything is working fine!

1 Like