X750, flashed rooter and now can't get back


I have an X750 that I installed rooter on. I’d like to go back to stock firmware, but it’s not going well. I’ve tried downloading the firmware from GL.iNet download center and installing via the UI in rooter. It says it’s being installed but then reboots right back to rooter. I’ve also tried bringing up uboot to no avail. I get the 5 blinks of the 5g LED followed by the power and globe LED steadily illuminated, but the router doesn’t seem to be listening on I’ve tried pings, loading HTTP:// in several browsers, etc.

Any ideas?

ping does not work in uboot failsafe. The most import thing to enter uboot is to plug in cable first before power on and get reset button pressed.

Pls keep trying and it should work.

Hmm, I’m not having any luck. When I try to connect I am regularly getting a connection reset error from the browser. One thing I noticed is that if I look at the ARP table for that interface, I’m not seeing an entry for I’d think that I need to see that in order to be able to connect to the router.


One more thing to check, when you configure IP manually on your pc, pls fill the netmask and gateway. Sometime is these info are not filled all you cannot connect uboot.

This is the procedure you should use, not the rooter UI Debrick via Uboot - GL.iNet Docs