X750 ultra low speed/rate and CA problem

Hi guys!

After trying for 3 days now to solve the problem myself, I turn to you in the hope that someone can help me.

In 2021 i bought the x750 Sptitz, and since the beginning i had some random “connection” failures from time to time.
The error is always the same (i have set up the right APN):

SIM card cannot be registered. Please check: 1. You are using the compatible modem for your carrier; 2. Whether a specific APN or data plan is required.

Mostly, a modem-reset would help, but sometimes i have to reboot the whole router.

2 days ago, suddenly internet speed/rate dropped to a sub-idrian level (200-300kb/s)
and the aforementioned dropouts now occurred every few minutes (“SIM card cannot be registered”).
I tried changing bands (as i am in germany, i tried 1, 3, 7, 8, 20, 28), which did not help.
By doing this, i also noticed that carrier aggregation does not work (AT command for CA result is “OK”)

In the night from yesterday to today, the speed suddenly improved a bit on its own:

Download: ~8Mbps
Upload: ~12Mbps
Ping: ~39ms
Jitter: ~4,12ms

Opening the control panel, i noticed a “frozen” modem interface (“cell info” is empty, and the “AT-command” is lacking ttyUSB2; so no commands are executable):
Also the main interface showed the simcard error again, although the internet was working.

So i did a router reboot, which destroyed the improved speed again:

Download: ~4,1Mbps
Upload: ~6,8Mbps
Ping: ~40ms
Jitter: ~14,27ms

On “Cell Info” all values except rsrq are “excellent” - rsrq remains at 12-14 / fair to poor, no matter where i position the router. currently it stands directly in the middle in front of the window pane, from where I can see the top of the cell tower:
(cellid redacted for privacy)

my firmware ist up to date: 3.215

In the beginning the errors were still bearable, with a modem reset/router reboot every few days, but slowly it really starts to annoy the sh*t out of me.

I hope someone can help me, I’m starting to go insane. Thank you in advance.

1 Like


does no one know anything? should i contact gl-inet directly?


32 KB/s downspeed… you have to be f*cking kidding me…

Can you post your modem settings?

Can you set the ttl to 65?

what exactly you need? i made a reset yesterday, and setup the modem to ttyUSB3, it improved a bit, but downloadrate is still ~8Mbps, but for now it seems more stable.

what i noticed: My simcard MCC/MNC is 262 07 which is “O2 Telefónica Germany”. But the modem connects to 262 03 which is “E-Plus Mobilfunk”.

is it enough to set the TTL in the simcard setup or should i do it additionally in the openwrt interface?

Just set up in modem settings

Download ~9Mbps
Upload ~9Mbps

but its more stable with ttyUSB3 then with default “device”

and still no CA

okay, i believe its an provider problem…