X750C4 new hardware version of x750? (solved)


this is a crosspost to Uboot web page is gone after flashing openwrt ... was [Glinet_gl-x750 new version (?)] - For Developers - OpenWrt Forum

"I got glinet_gl-x750, the sticker on the back of the device says “X750C4” and there is a FCC from 2019-06-19


Flashing Openwrt or LTE Openwrt (rooter) GoldenOrb is not possible
(“Device gl-x750 not supported by this image
Supported devices: glinet,gl-x750”)

I was brave and tried sysupgrade -F (force) but it (luckily?) did not work.
Any idea? I would be glad to help with further information."



Where did you download the openwrt source code?


I used snapshot (compiled) from here:



Our official firmware is based on AR71XX, the firmware in this link is based on ATH79, therefore, it is not possible to upgrade the system with sysupgrade command
You can upgrade this firmware in uboot,please refer to here

Thanks, (uboot) worked like a charm. Is there any reason not to migrate to ATH79 (stability?) or is it just on the todo-list?



GL is waiting on the new OpenWRT release before the upgrade to the new targets that is all :slight_smile:

One problem. ATH79 firmware cannot be upgraded fro AR71xx firmware. What should we do?

uhh that’s right, uboot does not present a web page anymore after flashing openwrt (I used rooter goldenorb). is there a tftp or any other way to come back to stock firmware :slight_smile:

Yours lopiuh

Jeff in the openwrt-forum says “It might be that “goldenorb, rooter” replaces U-Boot, which is not something OpenWrt does.”

do someone know how to repair uboot?



Flashing uboot will not damage uboot.

Pls go throught uboot again carefully. There may be something wrong. But uboot is not touched for sure.

shame on me, i fooled myself. What happened? Entering “” in firefox adressbar got autofilled to The uboot webserver correctly said “page [cgi-bin/luci] not found”. I was not able to go to plain (firefox feature or my illiteracy). Opened page in chrome [lopiuh 04.10.19: chrome does this as well, so deleting browser caches help] and the main page of uboot was shown.

Sorry folks for being in chicken mode. Everything went well and I am back on stock firmware.




I have C6 version ! Gl.inet is the best router for me ! Mfg

@lopiuh were you not satisfied with ath79-generic-glinet_gl-x750 ?

I u-boot installed vanilla latest release openwrt which went fine but no mobile interface :neutral_face:. So I reverted back to latest release gl firmware. Not sure if anyone else had mobile working with release openwrt …
This does work if one installs and configures proper kernel modules, protocols and drivers.

There are some problems with 19.07, especially that repeater can cause firmware to crash. Therefore, we have not provided the firmware supporting 1907 for the time being.

1 Like

Thanks for mentioning some 19.07 problems. I have, of course, not tested all that much. I do not use repeater functionality and 19.07 works for what I need.

Please Help!! I put my sim card in and add the correct apn settings, the device wont read the sim card i tried two different activated sim cards, i factory reset the router too nothing is working

Pls make new thread. This thread is too old.


Is it not recognizing the sim or recognises the sim and doesn’t work?

If it’s not recognising the sim are you using a nano to micro sim adapter? Sometimes the adapter is a little big thicker than the nano sim and needs to be shimmed or padded out to get good contact.

This was over a year ago. I’m trying to figure out how to upgrade to a 19.* version of OpenWRT on my X750C4. Has anyone done that successfully?