A pair of Gl inet devices (2nd repeater of the 1st one) not working properly

This is my set up: an ISP modem router connected to the WAN port of the first Gl_inet (GL-MT300N) device. A second Gl_inet device ( GL-AR300M) setted as a wifi repeater of the first Gl_inet device.
The DHCP of the repeater is now disabled ( when enabled the problems are tha same).
The problems are:

  1. Internet is working on the GL-MT300 but not working on the repeater.
  2. The clients ( domotic devices) connected to the repeater are’nt shared with the GL-MT300N.
    Is this set up not supported by Gl_inet devices, or there is something I can do to solve the problems I have ?

There are two types of repeater:

  1. WiFi as LAN.

You set up as Repeater in the Internet settings. You should keep the DHCP of the 2nd router enabled and change LAN IP from to others e.g.

  1. Bridge.

You set up in more settings->network modde->extender or WDS

This will extend the network of the first router and dhcp will be disabled automatically.

Hi @alzhao and thanks for your answer. My delay is due to the fact that my devices are in a remote location. Now I applied your suggestion (1st option) and something was surely improved but I found some problem. The repeater see the devices wifi connected to both lan ( 192.168.8.X and 192.168.10.X) but the 1st router ( also remotely connected “site to site” to another mango in my first home) can’t see the devices connected to the repeter but see only devices connected to it ( So, when I’m at 1st home I cannot manage remotely IoT devices connected to both lan but only those connected to the 1st router.

Sorry not very clear of your setup. Can you draw a diagram?

The router in House n1 cannot see IoT devices of the subnet of the repeater. In the same time the repeater of the House n1 can see all IoT devices, those in its subnet and those in the subnet of the router.
Finally, from the remote router in the House n2 I can see only Iot devices connected to the router and not those connected to the repeater.

I see. This is all expected behavior.

The reason is that, the Repeater create its own subnet and has a firewall, preventing access from the Router.

The solution is, set up the Repeater as bridge, aka Extender. You can do this in more settings->network mode in the admin panel.

In this way, all your IoT devices will be in subnet and will be able to access each other.

Ok thanks, we are anyway talking about a setting that does’nt need a cable
I hope from router to the bridged “repeater” ? Only wifi, correct ?

Yes. WiFi bridge is called “extender” mode in the router.

OK, thanks, I will try when I’ll go there !