Access Point with Static IP on router impossible

Hello GL.iNet Team.

I have recently purchased GL Flint2 Router and now trying to setup it. Firmware version - 4.5.6.
I need to setup it as an Access Point but use Static IP for router itself. I found that it is impossible now.
If I switch Newtork Mode to Access Point - the only option available (and automatically switched to) is obtaining IP address by DHCP. I also tried to change it on LuCi but stuck with some issues there also.

I’m not GL but have you tried setting the Static IP/DHCP Reservation to the Flint v2’s MAC on the upstream device? That’s typically how it’s done. It also ensure less chances of future DHCP conflicts.

I know that I can. And I have assigned it on DHCP server as Static Lease for Flint2 (as a quick fix). But it is bad solution. This is more of a temporary solution… Good router should be able to manage all this things by itself. Really, current available options look terrible (( For example, what if you have no access to DHCP server? ))

In luci or via SSH you can do whatever you like, so in emergencies this might be helpful.
But I agree that there should be some button within the GUI as well.

In LuCi it also has issues. You can’t switch addressing type in GUI due to errors.
In SSH I didn’t try. Maybe I will play with in the future if GL Team won’t add it to their firmware.

I disagree with your method but if you’re willing to take the risk of DHCP collisions, drop into SSH. All interfaces are in /etc/config/network. Find the one you want to set static:

	option proto 'static' # instead of dhcp
	option ipaddr '$myPreferredStaticIPHere'
	option netmask '255.255.255.0'

Use nano if you don’t use vi (opkg update; opk install nano).

/etc/init.d/network reload should do it.

Yeah, I know, thanks. I used OpenWRT for years.

I was just confused why there is no such obvious option.

GL seems to have it’s own ‘dialect’ when it comes to OWRT; just chk your repo feeds.