Adding Mullvad Wireguard Always fails

I am facing this issue which I overcame by first starting OpenVPN client connection and then adding Mullvad account number in Wireguard Client. Then I disconnected from OpenVPN and connected Wireguard and it worked on AR750s.

But this case is different for B1300 where I tried the same procedure but it never worked. I manually added settings from AR750s and copied in B1300 and named it “Mullvad” which you can see in the picture. By doing so I can only manually add one server.

@wellnw Please check it out!

I have checked the interface of azirevpn and mullvad, there is no change, it should be related to the network environment, my account can not be added.

Today, I test my account again, azirevpn and mullvad can add success.

You need to use the internal built-in function. Did you use as the following?

Always used internal builtin option choosing “Mullvad” from the drop down. Worked in AR750s but not in B1300.

Both these routers have test releases.