Adguard cannot see client ip addresss

Hello I enabled adguard also enabled the option to see the clients ip address in adguard. But it’s not working.
Any advise.

Do the devices use the router as DNS server or do they use another?

They are using router as the DNS but I want to use adguard as DNS server directly

You need turn off router dns server and turn on adguard home

I did. But it did not help. I disabled DNS server in the startup and let adguard run…but it appears as soon as I disable the DNS server the DNS resolution stops working.

Is there an official method to use adguard only as the DNS server and bypass local DNS server


That official.
You could check network interface in luci to make sure ticked default dns server

in luci i have redirected to adguard after moving dnsmaq to port 54

image

and disbale use isp dns in wan

My Adguard home is working but looks luci are different than your… :thinking:

yes, i changed to openwrt . the setting is same as like yours :slight_smile:

I have tried this option with no success

I found where from port 3053 in firewall port foward

So no official solution

I don’t get what you are trying to do and why.
If you want to use AGH only, make sure it will serve port UDP 53.