AdGuard configuration

I have my media box connected directly to my GLAXT1800 via ethernet and have AdGuard running on the router. This works perfectly well for all my other devices but on my media box I have several streaming apps that either won’t work at all or will find links that then won’t stream until I turn off AdGuard.
Is there any way to configure AdGuard to allow ALL traffic through the specific APPS (as opposed to allowing/refusing connection to the individual links that the streaming apps find)? Configuring link by link isn’t really feasible because they change every time you search.
Thank you.

AdGuardHome does not know which apps are sending the DNS requests. If certain DNS requests from specific media box apps are being blocked, then you can find those websites in the Query Log and whitelist only those websites from the media box.

The links are from specific blocked websites and you can whitelist all the links from those websites using wildcards, without having to whitelist every link from them. DNS Blocklists are finite, so you will eventually enable most/all of them.

I do not work for and I do not have formal association with GL.iNet.

Domains can be whitelisted/blacklisted from the AdGuardHome Menu>Filters>Custom filtering rules.

1. `||^`:block access to and all its subdomains;
2. `@@||^`:unblock access to and all its subdomains;

Go to Settings>General Settings first and “clear query logs”, then test your site/app when setting up/configuring/troubleshooting AGH.

You should be able to add @@||^ or any “Top Blocked Domains” to the custom filtering rules to whitelist the domain/sites you need to access.

You can add ||^ to blacklist domains/sites by adding them to the custom filtering rules if it is not included on a blocklist.

“Check if a host name is filtered” is also available on the bottom of the Custom filtering rules page to test domains and to block/unblock domains easily.

Thank you both.
Individual site filtering/blocking isn’t really an option because the streaming apps fetch links from all over the Internet and it would be too time consuming to investigate each one and then (if it’s being blocked) allow it through.
I was hoping to be able to just let all traffic via my streaming apps through on a per app basis.
So, as this isn’t viable, how do I configure AdGuard to allow all traffic in/out via the streaming box/device?
In other words, I have 6 devices connected to the router, how do I disable AdGuard for just one device please?

Manually set your DNS on that device to bypass adguardhome. and are unfiltered AGH dns servers or just enable private dns and use if available.

In AdGuardHome, go to Settings → Client Settings → Add Client.

Add the media/streaming box with a client name and its IP address as Identifier, then disable all the options for Use global settings, Block domains using filters and hosts files, etc. in the Settings tab. If you want, go to the Upstream DNS Servers tab to enter different DNS server(s) for the media box. Make sure to click the Save button.

Some streaming devices (e.g. Roku) do not allow manually entering DNS servers.

Thanks again.
I’ll try both methods and report back.
Happy New Year.

wcs2228 's steps should work better if its a permanent setting. I had not looked at client settings to see if toggling “use global settings” easily enables/disables the profile and on rare occassion, I’ll enable private dns or change client DNS settings for temporary access on the fly, while keeping AGH consistent with all clients.

You can also look at banip and luci-app-banip to add ipsets easily and still filter a lot of junk connections when AGH is bypassed/disabled.

GL on your New Years project!

Hello again.
I seem to be having problems, no doubt caused by myself.
Using wcs2228’s method, I have created two entries in the client settings section, one for my media box and another for my TV.

With AdGuard running ITVX, when played through the TV web-browser, reports that I need to turn of ad-blocking. If I turn off the global switch in the AdGuard entry for the TV client entry, I still get the same message. After making/changing anything in AdGuard I always disable then re-enable to main protection tab. If I turn off AG completely, ITVX works perfectly via the browser.
I have tried setting up the entries using ip address and mac address but still the same.
Any thoughts on what I am doing wrong please?

The IP address looks like your only option as an identifier with the default settings (dhcp source and static IP’s)

You can try deleting the client(s) and adding 2 entries to Menu>Filters>Custom filtering rules.

@@||*^$client=<media box IP>
@@||*^$client=<TV IP>

I tested AdGuardHome by disabling Use global settings, etc. for a client device. When I checked Query Log, none of the DNS requests from the device were blocked. When I re-enabled Use global setings, some of the DNS requests started getting blocked again.

After you turned off Use global settings, etc. for your TV, did you see any DNS requests from the TV get blocked? Also, did you set different DNS server(s) for the TV (e.g., in the Upstream DNS Servers tab? If you do not, then your global Upstream DNS Servers are used, some of which could have ad blocking by default.

Hi wcs2228.
I have just tried again and added to the upstream as suggested.
It’s all very weird.

First of all, if I try ITVX via the inbuilt app on the TV, it works regardless of whether AdGuardHome is activated or not (but with ads as expected).

Via the web-browser, with AGH off, ITVX works (but another issue has become apparent that I’ll come back to). With AGH on, it’s hit and miss.
If I add the various filters (as kindly suggested) the results are odd.
I’ll use AquaMan simply as an example.
AGH off, plays fine.
AGH on, I get the error message about adblocking.
Add suggested solution, go back to AquaMan and it will now play (from the same point) but if I try to scroll forward/back, I get the adblocking message again.
The logs show (with the filters applied) some stuff going through and other stuff blocked.
The only reason I was trying to use ITVX via the browser is because I was hoping (as with All4) that the web-browser version would be better resolution than the app version but this doesn’t appear to be the case with ITVX. Plus, ITVX via the browser has an issue where “full-screen” toggle doesn’t work properly.
So I am going to just use the app from now on.

Now for the important question :grin:
Does anyone know if its possible to block ads on the built-in YouTube app?

Thanks again for your help and time.

By default, when you run AdGuardHome on the same GL.iNet router, the clients all show up as localhost in Query Log, so the Client Settings method may not work. If this is the case in your router setup, then you can make a change to show the correct clients:

I do not think you can block ads in the YouTube app, but can block ads in a browser.

Sorry for the late reply (real world stuff happened).
Thanks again for all the help and suggestions.