AdGuard DNS ignored on GL-AX1800 (Flint)

I’ve enabled AdGuard and have set the required DNS servers for it to use (I’m using Quad9).
However, the router completely ignores the DNS servers configured in AdGuard and uses my ISP’s DNS servers instead.

Is this a bug or am I missing something here? I’m not using VPN or anything of that sort and AdGuard is enabled and blocking ads just fine.

This is only the DNS for the interface, please see the description on the DNS page.

If you set custom DNS servers (include ADguard Home), any domain names will be resolved through the DNS servers set here instead of the one obtained from Ethernet, repeater, cellular, tethering or VPN configuration DNS servers.

1 Like

Thank you. If possible, I’d suggest changing the displayed DNS server addresses on the “Internet → Ethernet” status page when AdGuard is enabled.

Thanks again!

1 Like

I prefer the DNS addresses to be as shown because they relate to the IP address and other information also shown for the Ethernet WAN connection. I think an informative message would be adequate for explanation.

I do not work for and I do not have formal association with GL.iNet.