Adguard home - Brume Gl2500

I am using the Adguard home and have activated the statistics and logs for 90 days. Still, when I try to see, for example, the list of Blocked adult websites that appears, I receive an empty log like they aren’t working correctly, and this is also happening for other options like Blocked by Filters. I can see the information for a specific time like today if I need to see something regarding the last day I can’t.

Brume 4.2.3 version 5

Are you sure all your devices are sending all their DNS requests to the Brume 2 and AdGuard Home?

36,379 DNS Queries over 90 days seems somewhat low. I do not know how much web traffic you generate, but I go through a number of times more in only 7 days.

I do not work for and I do not have formal association with GL.iNet

This number is only for 2 days because when I discovered the issue I reset all the statics and logs. It is not working properly. For example now the adguard shows me around 50 blocked adultos websites when I try to see the list. This appears empty

Adguardhome is on or off?

Of course, is ON…

Now I have logs for the last 6 minutes,

Any solution here???

What version of AGH are you running?

Version: v0.107.26, last updated from GL,

I tested it for two days and It only able to save block information for the most recent day.

I’m in touch with the author of AdguardHome.

You could also ask questions directly at AdguardHome,too.

This is a very old version and unlikely to get much support from the developer other than saying to upgrade to the latest version and try again. I would recommend upgrading. You can follow my example here on upgrading.

Thanks, for me, it seems a little complex steps. Any chance to do something wrong that can cause issues with my device?

Why Doesn’t GL update the ADH to the last version?

Thank you, let me know about the solution

Do the following and I’ll add support to my updater script:

From a ssh prompt:
opkg install file
file /usr/bin/AdGuardHome
cat /proc/gl-hw-info/model

Send me the output of those commands

1 Like

Thanks, I am traveling now and will return in two days, and I will do that.

Hi shieldtv61:

You need to change a configuration ‘/etc/AdGuardHome/config.yaml’ manually:Set ‘file_enabled’ to true.


Then restart device or AdGuardHome.

My Brume GL-MV1000W has “true” as the AdGuard Home default setting, but my Brume 2 GL-MT2500 has “false” as the default. I noticed the difference when I compared the config.yaml files during the migration from Brume to Brume 2 and set it to “true” also.

It seems it has changed on the newer AdGuard Home version(s) for some reason. I think the GL.iNet firmware should set it to “true” as the default because it is obscure and requires SSH login.

I do not work for and I am not directly associated with GL.iNet

By default the GL.iNet AGH install will write your log files to /tmp which gets erased on reboot. I would recommend moving it to you mmc drive, if you have one. Another issue with tmp is that it may be very small. On Beryl MT1300’s it’s 120MB.

I run AdGuard Home 24/7 as a DNS server and only reboot for maintenance or if there is a problem (in months), which is acceptable for me. If storage is a problem, why was the previous default set to “true”? What is the name of the log files in /tmp?

For 7 days of logs, I did not encounter any /tmp problem on my GL-MV1000W. The /tmp on my GL-MT2500 is 512MB and other newer routers probably have a larger /tmp also. I suppose there “may” be a /tmp problem for the maximum 90 days of logs.

I checked on my Brume 2 GL-MT2500 and could not find AdGuard Home log files in /tmp. I believe the log file is /etc/AdGuardHome/data/querylog.json and, if so, would not get erased on reboot.