AdGuard Home Handle Client Requests does not work with Override DNS Settings for All Clients

Per topic, when enabling “AdGuard Home Handle Client Requests”, if “Override DNS Settings for All Clients” is enabled, all requests in AdGuard home show up as 127.0.0.1 (localhost) rather than from the originating client. Disabling “Override DNS Settings for All Clients” allows “AdGuard Home Handle Client Requests” to work as expected.

I would like both to work, so clients cannot bypass my router’s DNS, but the clients will show up in Adblock Home.

Model: AX1800
OpenWRT: OpenWrt 21.02-SNAPSHOT r16399+159-c67509efd7
Version 4.2.1 release 4 (compile time 2023-04-14 21:38:06(UTC+08:00))

Behavior is also the same on AXT1800, 4.2.1 release 4

You can turn below option on, which is the same thing as Override DNS Settings for All Clients

Recommendation for the UI, then. In Settings → Network → DNS, when Adblock Home is enabled, there is the warning message below, and the ability to configure DNS disappears.

AdGuard Home is enabled, the router must use the DNS server provided by AdGuard Home, you can’t customize DNS servers.

Recommendation would be to disable then grey out or hide the option to “Override DNS Settings for All Clients” because using AdGuard Home to Handle Client Requests effectively provides this same functionality and they are not recommended to be used together.

I can confirm that enabling “AdGuard Home Handle Client Requests” STILL shows 127.0.0.1 :smiley:
(at least on my AX1800)

I suspect that “Override DNS Settings for All Clients” has the router itself (i.e., IP address 127.0.0.1) forward DNS requests to AdGuardHome. My Asus router has the equivalent override DNS setting and that is the way it works, with DNS requests showing on my AdGuardHome server as coming from the router IP.

I do not work for and I am not directly associated with GL.iNet

Youre right!

once i disabled “Override DNS Settings for All Clients” and enabled “Adguard Home Handle Client Requests”, it worked! I now see IP addresses of clients in Adguard.

I would be HONOURED if Custom names set on “Clients” page of GL.iNet Admin Panel can be synced with Adguard (so users see names instead of IP addresses). :thinking:It maybe possible to manually do this in Adguard’s Clients page (http://192.168.9.1:3000/#clients) but cool if done automatically by GL.iNet

Bit of a NOOB question here, but what are the pros/cons of enabling this? does it have any impact on VPN? Thanks!

@conor - the correct configuration for Adblock Home is:

Network → DNS → “Override DNS Settings for All Clients” → DISABLED
Applications → Adblock Home → “Adguard Home Handle Client Requests” → ENABLED

None of this will have an impact on VPN.

Enabling both is unnecessarily redundant (increased complexity with no value) and will make all DNS requests look like they are coming from your router (192.168.8.1 if using the default) in Adblock Home. Which is why I request above that GL.iNet “gray out” the ability to enable both in the UI.

Using the configuration above will allow you to distinguish DNS requests between client devices (so you will know, for example, which clients are making adult website requests that are getting blocked) while also ensuring that clients cannot bypass Adblock. If you have specific devices that you really want to bypass adblock, then you can create an address reservation for your host (Network → LAN → Address Reservation) and an Adblock Home custom filter rule. For example: @@||*^$client=127.0.0.1 will unblock everything for localhost (127.0.0.1).

Hope this helps.

1 Like

Sorry, most confuse what talking about ‘adblock home’? You mean AdGuard home?
I never heard 'adblock home":roll_eyes:

Yes, I was referring to Adguard Home.

1 Like

this is the solution. thank you
IPs can be named in Adguard Dashboard → Settings → Client settings