Adguard Home Issue?

Hiya GL community,

I have a Slate AX (GL-AXT1800) router that I bougtt a few months ago. It’s current up-to-date on firmware and it’s stock from GL.Inet, but I can never get the Adguard Home to work properly. I’m currently on 4.2.3 release 5.

Adguard Home, once activated, only stays running for 24 hours (give or take a few hours) until it stops producing internet connectivity. To resolve this, you have to restart the device. It happens also always, and I’ve hard reset the router, I’ve reset Adguard Home settings, I’ve ensured the filters are not the issue or my connected devices, and I’ve ran out of ideas.

If anyone here can offer any insight or provide some assistance, I would greatly appreciate it.

Did you choose too many entries ? Memory is limited on ax1800 and axt1800

Thanks for the response.

What do you mean by too many entries?

I have a Flint and a Slate XL I only have a few entries in my AdGuard I’m also running 4.2.3 release 5 on both my routers I have the same trouble, AdGuard just seems to stop and block everything randomly or can run a week it’s a pain I wish I new the answer as well, you can’t even log into the GUI and like you a hard reset is the only option, and as of 2 days ago AdGuard blocks Netflix the website the app and the steaming service, but I feel this is something that Netflix has done, disabling AdGuard home and Netflix runs fine I mentioned this because I’m sure a few people will have this issue.
agh means the number of blocked lists, my flint has 10 my Slate has only 4
See below

1 Like

Thank God someone else is experiencing this!!! I thought I was going crazy here @Radiocrazy.

You seem to have a lot more filters than I, however. I only have "Adguard filter, Adaway, and “No Tracking Blocklist,” so just 3. Memory and flash both have space, so I doubt it’s that.

You know, I only purchase GL.iNet for out-of-the-box Adguard support. If it can’t do that, then I see no point or value in these routers for ME. Therefore, I hope this can be resolved.

I don’t feel you can blame GL.iNet I personally think it’s more an AdGuard problem with it disarmed I have no lockups at all, on saying that it is complicated blocking ads, as ad companies do everything they can to bombard us with crappy ads I hate them.
AdGuard has lots of settings and options, how often do you have a lock up?
I’ve not tried it but I wonder what would happen if it was run as an experiment with an empty ad list also block services.
Look what happened just before I posted this, after I could not log into the router.

I had to restart as well lost the internet totally try this for a few days see what’s happens, no ad blocking of cause.

1 Like

@Radiocrazy thanks for the follow-up.

I’m not necessarily blaming them, but when you advertise out-of-the-box Adguard home support, then you have to follow through with that regardless of who’s to blame here.

I, for one, hope that this gets resolved somehow and sometime soon otherwise my second Gl iNet router is going right back to Amazon for a full return and refund along with a not-so-pleasant review.

Personally, it occurs about every 24 hours (give or take a few hours). I can’t seem to get this resolved no matter what I do. It’s not a great experience and it gets frustrating at times.

As far as experimental goes, I have no experience with that nor do I know how to go about testing that. I’m hoping I can get a response by the next business day from a moderator or a technical support specialist before I file for a return on Amazon.

Edit: thanks again @Radiocrazy for the additional info. I followed your instructions and replicated the same thing. Let’s see if that helps. Meanwhile, whilst attempting that, something odd happened. So, I turn on AGH, with Adguard Handle Client Requests, but once I visit the AGH admin page (settings), it says protection disabled, lol. This tells me that the mobile app and actual admin settings are not communicating well.

Anyways, the pics below show me doing what you’ve instructed. Fingers crossed that it helps determine the cause.

you may also disable agh and run the ad blocking through nextdns configured via dns, as a temporary measure

otherwise, be ready to get the log file when the problem occurs, admin/support would probably ask for it

Thanks for the swift response.

Sounds good. I’ll be ready to do that should it be necessary when the time comes. Albeit, I’ll likely need instructions on how to accomplish that, it shouldn’t be a problem if informed.

Well, since support seems to be somewhat non-existent, I’m returning my router today and leaving an honest, not-so-pleasant review. I expected some help from the Staff, but I guess this may have been for the best.

Shame I do like these routers, I still say it’s AdGuard to blame (especially settings) I have only 3 blocked lists now, I believe the problem lies with the updating the lists if one don’t get updated maybe due to the relevant site list down it freezes AdGuard and then blocks everything, blocked services seem fine as there not updated as such, I have solved my blocked Netflix problems by white listing the relevant sites so that’s solved.

You are a very stand-up person, and I appreciate your support and advice. You’ve been of help from the start unlike the staff here. However, I’ve sadly returned it now.

Thanks and take care, @Radiocrazy !

All the best agh nice chatting to you.

Hello readers,
it’s an old discussion here, but I thought my experience with my GL-AX1800 might help other frustrated users.
I solved all problems without loosing any functionality. My router runs WireGuard-VPN parallel to AdGuard without limiting entries and it runs very great since months.
The one thing, what solved everything: Use an USB-stick to extend RAM. Finally 1GB is more than enough. After some days it uses a bit more than 500MB. You can configure it in luci → system → mount points. You can even copy the operating system to the USB-stick and run it completely from there (but I couldn’t detect any advantages doing so).
If you use an USB-stick 3.0/3.1/3.2 it could block your WLAN (it’s seems to be a general problem with USB-3.X). Find one with low emission. Mine is a Sandisk 128GB 3.??, which run’s great, no effects to Wireless.
Any of my tested 3.X USB-sticks became hot, very hot, and one died after some days of using. So you need to cool it (passive). I did it the idiots way with some aluminum foil wrapped around and formed some “antennas” to increase cooling surface.
Hope this helps you, bye.