Adguard Home not blocking services on wifi devices

I have two gl-inet routers (1 GL-MV1000W and 1 GL-AX1800) where, separately, I configured them to both adguard home and on both I have the same problem.
now the traffic of the devices connected via ethernet is blocked (or diverted) while for the devices connected via wifi there is no type of block, and I cannot find a solution.
I have already tried setting up DNS on the wireless device but nothing

Hi and Welcombe, I have a GL-AX1800 and use AdGuard all the time have you got Override DNS Settings for All Clients selected i just tried one of those stupid social media sites Twitter on my iPad and iPhone and its unavailable so it working fine.

Do you mean that the device connected via cable works correctly, i.e. have Adguard working

but the device on wifi does not have Adguard? But you don’t need to set up dns on the wireless device, right?

The router should not set any Custom DNS Server → Manual DNS Server Settings and all your client devices should be set up to use DHCP from the router, without any manual DNS setting on them. Check that the DNS server on all the client devices is the IP address of the router (e.g.,

I do not work for and I do not have formal association with GL.iNet

Ok, so I partially fixed it but on my android device it doesn’t work, I keep viewing adult content (I took a site for example) and I don’t want this to be accessible

that’s right, I would like mobile devices to be blocked as well

exactly, if I set alternative dns I browse anyway and both the advertising and the sites I do not like are displayed by the wifi devices

What is the wireless device?

Pls note, Adguard need to take control of the dns query.

But if you dns on your client devices is encrypted, Adguard home will not be able to control it.

For example if you use windows and set the dns to, it will automatically encrypted.

So please check if you wifi devices use encrypted dns.