AdGuard with ExpressVPN

ExpressVPN and other commercial OpenVPN providers probably push their own DNS servers to the client.

Try downloading and editing their OpenVPN config file to disable their DNS servers and putting in your own DNS servers. Add the following section before the Certificate section in the config file (a.b.c.d and e.f.g.h are your own DNS IP’s).

pull-filter ignore “dhcp-option DNS”
dhcp-option DNS a.b.c.d
dhcp-option DNS e.f.g.h

I do not work for and I am not directly associated with GL.iNet