AdGuardHome on GL routers

I used port 3053 instead of port 53 because I needed to be compatible with DHCP and other DNS Settings
Can you describe your problem in detail?

I expose AGH portal on port 2000
My goal is to reach it with url adguard.home:2000

I did this DNS Rewrite:
adguard.home —> 192.168.8.100

In the log i correctly see the resolution, but browser showed an error page (about dns problem)
So i disabled dnsmasq service, changed the AGH listening port from 5353 to 53, and now able to reach AGH with URL adguard.home:2000

before this trick i was able to logon only with 192.168.8.100:2000

About you, why 3053 ??

Disable DNS Rebinding Attack Protection if you use private IP address

1 Like

Possible to update to AdGuard Home v0.103.2 on ar750s

1 Like

It was released 3 hours ago :rofl: :rofl: :rofl:

2 Likes

Of course, I will update as soon as possible.
V0.103.2 has been fully compatible with the GL. INet router, soon GL will release the official version, and later AdGuardHome can be upgraded directly on the GL router if the updated version is released.


:grin: cant wait fore good stuff

thanks luochongjun , sorry but am realy like glinet products

1 Like

I updated the firmware of AR750S and MV1000

1 Like

Hi, possible to build adguardhome for B1300 based on stable firmware 3.027?
testing firmware 3.104 breaks ddns.

1 Like

hi @luochongjun

it would have been REALLY helpful if updated releases (like the one you have just added) would either -
(a) have a meaningful file name (with a proper sequential ver/build number etc),
and/or -
(b) would at least have proper description in the ReleaseNote.txt file in that folder. it would be helpful to know which build it is based on and what was modified/rectified/added so we know what to test for

This has already been covered before. Since the Adguard firmware versions are snapshots/testing versions, there are no changelogs for them. When a new firmware is set to Release so it appears in the UI as a new update, then there will be a list of changes.

1 Like

I’m not able to disable it on the openwrt-ar750s-AdGuardHome 07252020 snapshot via the GL interface. The status message at the top is -700. I cant find a corresponding log in /var/log/ and nothing was written to /tmp/system.log.

EDIT: I was able to disable it via the LUCI interface.

Please try to turn off your manual DNS settings first.

I don’t have any manual DNS settings, however I’m using Mullvad VPN via Wireguard and have AdGuard Home enabled. Since they both change DNS, I imagine I’d have to disable both first then?

Can you update the S1300 as well? Thanks :smiling_face_with_three_hearts:

Wow just tested today in AR300M. Most of things work including add regional DNS filters, change upstream DNS, etc. I am using it together with wireguard (warp+, cloudflare dns in wireguard setting) and as for me, using Cloudflare (DNS over TLS ) in the upstream DNS setting (AdGuardHome) fails DNS resolver for all client. Everything’s back to normal after reverting back to standard DNS over udp.
Thanks for this additional update.

1 Like

I have updated the firmware of S1300

1 Like

@luochongjun

I updated to that new version, but the Adguard version is broken. It shows as:
“Version: -SNAPSHOT-7c836c2”

So Adguard keeps notifying of a new version at the top of the page.

" AdGuard Home v0.103.3-SNAPSHOT-5188da6 is now available! Click here for more info."

I noticed that I will try to communicate with AdGuardHome and get back to you.

1 Like