AdGuardHome on GL routers

It’s the links that the OP who started this thread posted to get the customized firmware with adguard home installed.

The links in the first post are dead, @radishman needs to update them

I see. It is an old post and I just updated.

Update on Feb 14, 2022

AdguardHome is available for S1300, MV1000 and AX1800.

Routers like AR750S, MT1300, B1300 can also run AdguardHome but they may not be powerful enough to run it smoothly.

Please update to firmware 3.105 and newer.

If the firmware does not comes with AdguardHome by default, pls update Plugins and install gl-agh-stats

1 Like

@radishman Why does the Adguard only display the router itself as a client? I experience this behaviour also when using an alternative DNS server (Pi-hole). From your screenshot i see the same behaviour.

Because the clients are not querying AdGuard server directly. GL-AX1800 have dnsmasq binded to the default DNS port (53) and AdGuard binded to port 3053.

I tried to disable dnsmasq DNS by configuring it to bind to another port but it doesn’t work as expected and that left DHCP in a broken state. The solution was to remove dnsmasq and use odhcpd instead.

I don’t recommend messing with this unless you know what you’re doing. But it basically you have to connect via SSH to the router, edit AdGuard conf to bind DNS to 53 and follow instructions from the link bellow to remove dnsmasq and set up odhcpd.

Apparently everything is working as it should but I haven’t rebooted yet.

EDIT: I had to manually add odhcpd to the startup.

Here I found a the solution to the problem; Source of DNS queries not seen in adguard of alternative dns server like Pi-hole - #8 by wcs2228

I successfully disabled DNS functionality in dnsmasq and enabled AdGuardHome as DNS server.

Stop dnsmasq and AdGuardHome:

/etc/init.d/dnsmasq stop
/etc/init.d/AdGuardHome stop

In /etc/config/dhcp, replace the following lines:

option noresolv ‘1’
list server ‘’


option localuse ‘0’
option port ‘0’

In /etc/AdGuardHome/config.yaml, replace:

port: 3053


port: 53

Start dnsmasq and AdGuardHome:

/etc/init.d/dnsmasq start
/etc/init.d/AdGuardHome start

Back up the 2 files before starting changes and restore the 2 backup files to reverse changes.

EDIT: Configure DHCP server to give DNS as the router’s IP address via LuCI → Network → Interfaces → LAN → Edit → DHCP Server → Advanced Settings → DHCP-Options. Enter the following and click Save, then click Save & Apply:


If you have changed the router’s IP address from the default 192.168.8, then enter the new IP address preceded by “6,”

EDIT: Here is the OpenWRT reference:

I do not work for and I do not have formal association with GL.iNet


Thanks. I did something similar with dnsmasq but through Luci and it left DHCP was broken. I should have edited the config files directly.

Newbie question, where can I execute the command? I accessed LUCI but no idea in how to procedure from there.

The editing of files under /etc is to be done by logging into SSH on the router. The remaining steps can be done in LuCI.

Pls learn ssh and winscp

Thank you for sharing!

Thank you! Worked. The only issue I am having now (not sure if it is the cause) is my VPN when connected does not respect the rule of VPN Policy Base on the Target Domain or IP

Hi, I just updated the AdGuardHome version in my Gli-Net M3000 router to version
I used the GitHub version AdGuardHome_linux_armv7.tar.gz.
It came to my attention that the AdGuardHome version from the router I flashed yesterday is much bigger than the version from GitHub. Do you know why?

AdGuardHome_bu is the version from the beta4 firmware.

Gli-Net M3000 router’s current AdGuardhome version is v0.107.8 AdGuardHome_linux_arm64
Need to check changelog about size/optimization.

I was using the 32bit version instead of 64bit. However, that doesn’t change the size of the file much.
Question here: Why is the original file on the router 12 MB bigger than the newer one in the GitHub repository?

That’s Adguardhome v0.107.24 has size optimzation on older version v0.107.8.

1 Like

I got this error message when i wanted to install AdguardHome plug-in. I only just had the router just over a year.

Collected errors: * verify_pkg_installable: Only have 5984kb available on filesystem /overlay, pkg AdGuardHome needs 10442 * opkg_install_cmd: Cannot install package AdGuardHome.

my current firmware - 3.216

This error indicates that the storage space is insufficient to install adguardhome.

what can i do to create space, please?