Amateur piratebox mistakes

Hello all- I would like to start over with piratebox. I installed it once, then made mistakes with passwords. What I would like to do is start over. However now I cannot log into the GL-AR150. I’ve tried resetting the device, but no dice. All I want to do is re-install factory firmware and then try again with piratebox install. How can I log into the router? Thanks to all

I don’t own a GL-AR150, but I would think the simplest approach is to flash the official GL.iNet firmware through U-Boot

I’ve tried UBOOT, but the problem is the same as before. My browser(chrome) will not connect to router. Just times out.

What OS are you using on your computer? If I remember correctly, there was an older U-Boot that would only work with Windows. This was later updated and all OS’s could connect.

I’m using a Toshiba Satellite lap top running Win 10 Pro.

Have you set a static IP address on your laptop’s Ethernet interface in the subnet?

(U-Boot does not provide DHCP services)

no,that is not in the instruction

all I can conclude is that uboot does not work, at least not for me.

Since U-Boot does not supply DHCP, you will need to assign a static IP address to your Ethernet adapter, such as with a netmask of (or, in CIDR notation,

Also confirm that you don’t have a conflicting IP assignment in the subnet. For example, wireless from another AP assigning you an address in the subnet. If you do, disable wireless or that interface while trying to connect to U-Boot on the AR150.

As Jeffsf indicated, the instructions do say to set your IP to a static value.

He gave you the relevant part but the whole instructions are here:

1 Like

do I have to disable my primary internet connection?

If your laptop is getting an address in the range from your primary router, you either need to temporarily disconnect it, or change the subnet your primary router uses.

Otherwise your laptop will have two interfaces on the same subnet, which is generally a misconfigured situation.