Any way to FULL factory restore?


As mentioned in my other post I have an S1300 that I have been messing with the partitions on the Glinet and custom firmwares.

although its working I’m pretty sure I have deleted important patritions. Is there any way to fully restore the box to the factory build?

I have followed the glinet restore along with the full uboot restore but it doesn’t seem to change the partition sizes back to stock.

Can anything be done? Thanks

Hi there!,

Hmm as far as I know via uboot is the right way to do it.

But you have to use the factory format image of your router and not the sysupgrade.

From my experience I had this happening to my flint router, I updated this router to openwrt wlanap 21.02 but then tried to use lucis upgrade with the factory default image and that caused a brick for me (I suspect probably aswell partition problems).

But when I booted uboot then it worked great.

So if I understand your question correctly:

  • have you checked you are using the factory image and not the sysupgrade one?

  • or do you mean uboot might be gone but your router still works?

If all fails… I would suggest using a more dangerous command I hope somebody with more experience can also respond to this thread otherwise just wait beforehand doing so, since ive readed somethings for the ax6s router and partitions.

What you should do is, scp into your router and then upload the gl-inet factory bin and you rename it to factory.bin, from there you ssh in your router and go to the location and then you use the dangerous command:

mtd -r write factory.bin firmware

However as I said please wait till someone from gl-inet responds cus maybe you have to define something after firmware aswell.

Edit: Edited command with the write argument

Thank you for the reply. I’m using the firmware here GL.iNet download center

if you know where to get the factory one please let me know.

Uboot and the box work but I think the partitions are not how they are when I got the box. Mtd seems to be mounted on the emmc.

I like the look of the Mtd command but will await further instruction. Thanks again

Ah, I noticed the factory image is already inside it on the link you sent me.

I think the proper way would be with the mtd command since this also restored partition sizes within the flash, though if you have multiple ones even in factory, you might need a parameter after the firmware, perhaps @alzhao can give a insight?

Maybe @hansome can have a check.

Thanks again for the response. I won’t do anything until I hear back so I don’t break it! heres the restore files and instructions. I was giveb them by @hansome on another thread. Thanks everyone!