Any way to set MT300N-V2 WiFi bandwidth to 20MHz?

According to my WiFi scanner, the MT300N-V2 channel bandwidth is set to 40MHz.

Is there any way specify 20MHz? Perhaps a configuration option in /etc/config/wireless?

https://openwrt.org/docs/guide-user/network/wifi/basic#common_options1

You can change the speed on the web to 144.4m and then change the HT40 to HT20, Or you can just modify the config file /etc/config/wireless.

QQ%E5%9B%BE%E7%89%8720190810114302

@dzwghx
I found I could not change the speed from 300M to 144.4M through the web GUI. It refuses to make the change. It seems that parameter (and the channel number) can’t be edited when it’s in repeater mode.

I was surprised to see that the MT300N was running at 40MHz, since the WiFi network that it’s associated with (on the WAN side) is at 20MHz. I had expected it to adopt the same parameters (channel# and b/w) as the network it’s repeating.

Since the GIU approach didn’t work, I followed your advice to tweak the /etc/config/wireless file. I found that it already contained option htmode ‘HT40’, so I changed it to ‘HT20’. Presto - problem solved. The MT300N is now using 20MHz, a better configuration in my crowded WiFi neighborhood.

I see that in the example you posted you have option noscan ‘0’. My unit has noscan ‘1’. Which is preferred?

Thanks.

At least as I understand it, noscan is deprecated as it is not legal to disable either DFS or co-channel detection in most jurisdictions. The line should be removed from your config.