Apple TV VLAN can’t see Main LAN devices

I’ve bought a GL-MV1000 Brume (no wifi) to use it solely as a wired VPN router for my Apple TV. I’ve setup mDNS (following this guide) Resolving mDNS across VLANs with Avahi on OpenWRT – Just another Linux geek

Simple setup with only two interfaces (LAN/WAN):

ISP Modem/Router (192.168.0.*)
├─  GL-MV1000 (192.168.8.*)
|   └── Apple TV
├─  All our other devices (phones, laptops)
├─  Airplay speakers (KEF Living Room)
├─  Airplay speakers (Sonos study)
└─  Other IoT Devices (Tado thermostat, etc.)

I’ve installed mDNS, Avahi and this means that my phone I can see the Apple TV, etc. I’ve also opened mDNS ports 5353 on the MV1000. So far this seems to work (only the Apple remote on my phone can’t find the Apple TV).

The main problem I cannot seems to solve is that the Apple TV can’t find any of the connections outside it’s subnet/VLAN - which means I can’t play from the Apple TV to the Airplay speakers as they don’t show up.

Any options? Did I miss some port forwarding settings? Thanks!

You Apple TV is behind VPN, you should use vpn policy so that your apple tv can find local devices.

Use domain/ip based policy and do not use vpn for network

Thanks, I was able to try this but without luck. Still the devices outside the GL-MV1000 LAN zone don’t show up. I’ve double-checked that everything is as you mentioned and restarted the device.

If you do not use vpn, can the Apple TV find other devices?

If still not it may be that Apple TV can only find devices on the same subnet. Then this has nothing to do with vpn.

Thanks for your reply - much appreciated. I can confirm that without VPN the Apple TV can’t find devices on the other subnet. I assume that the VPN is “off” when I didn’t configure any VPN settings?

I’ve also tried to install mcproxy to check if at least it could find the Sonos devices according to this post:

Unfortunately this doesn’t work either. Hope I can make it work as I’m not an expert in networking and for all other devices I’d like to use GL iNet too if I can make it work.

Thanks again!

Got it working. I reset the Brume, re-installed Avahi and did port forwarding in LuCi. Seems to work now - also when Wireguard is configured!

1 Like

Glad that you got it working. The problem was port forward?

Don’t know exactly what it was. However, mDNS responder is working now and all devices can see eachother across the subnets. This means that the Allow-mDSN rule (see below) is working.

Unfortunately now it seems I still can’t access my LAN from WAN. The Apple Remote on my phone app for example can see the Apple TV (because mdsn is working) but can’t connect. I even tried to create a Allow-WAN-to-LAN rule to allow all traffic/ports from WAN to LAN in case I forwarded the wrong port. What am I doing wrong? (I forwarded ports 80 & 22 in the Glinet UI so I can ssh into the device at least and that works).

PS: Really trying to make this work as a don’t have experience with OpenWRT and wanted to see if in our new house I could install Brume + Switch + 2x Velica APs however I think I might lack the experience/confidence now to get it working unfortunately.

Any further solutions or suggestions on why the Allow-WAN-to-LAN rule is not working? Even with this rule in place, when I put my Hue bridge behind the Brume (to test) I can’t reach the bridge through the app from my main wifi. In theory WAN to LAN traffic should flow freely?

Any help is appreciated. :slight_smile:

It is two subnets. Just enabling wan-to-lan rule may not help.

Maybe you should forward more ports?

Hey Jopie, I followed your work and got as far as you did. Have you managed to complete the setup so that AirPlay can connect as well?

Devices in 192.168.0.* need to know how to reach 192.168.8.. The easiest would be a static route in your main router (the one in 192.168.0.) pointing to the brume.

I removed double NAT by using the Brume as my main router now as I was able to get the PPPOE credentials so not using this setup anymore unfortunately.