AR-300M - Unable to connect to hotel Wi-Fi for longer than a few hours (with auto-reconnect enabled)


#1

I am unable to connect the router in WISP mode to the hotel Wi-Fi which has a captive portal. Once I authenticate to the captive-portal using one of my devices connected to the router it works fine for several hours and then suddenly stops working. When I check the status page I see that there is no connection even though the ‘Auto scan & reconnect’ option is checked.

I have to manually open the list of saved connection and click on ‘connect’ after which it disables the LAN Wi-Fi briefly and connects successfully to the hotel Wi-Fi after which things work for another few hours. I have the ‘rebind protection’ option disabled as captive portal didn’t work until I disabled it.


#2

when you reconnect, does the portal page pop again?

This seems that the connect is not stable. If the router failed too many times to connect, it just disabled it.


#3

Hi, thank you for replying. No, the portal page does not pop up. When I authenticate to the portal it gives me 168 hours before expiry (1 week) so it would seem it has nothing to do with the portal page. I just have to manually reconnect by clicking on ‘saved stations’ and then ‘connect’ and it works again.


#4

You disable repeater manager which manages the wifi repeater.

ssh to you box and do the following:

killall gl_health
mv /usr/bin/gl_health /usr/bin/gl_health1

In this way the router will always connect to the same wifi. But if it cannot connect, its own wifi will not show up. So you may need a cable to configure it again.


#5

Thanks, that worked! I’ve been connected for the last 24 hours without any issues.


AR750S Connection lost