AR-300m upgrade uboot to newer verions


#1

I’ve a AR-300m with older version of uboot so I only see the option to update NAND. How can I upgrade uboot itself and where can I find the necessary files.

Thank you


[AR-300M] Change firmware with button (NAND and NOR)
#2

First, you need to have usb uart adapter, solder the serial pins and setup a tftp server. Can you?

Then I can send you the new uboot and give you the guide.


#3

I have soldered the serial pins and I have a usb uart adapter. Can you please send me the files and guide.

Thank you


#4

I would like a copy as well please…


#5

Can you send me the uboot as well?


#6

also to me if it’s not a problem :slight_smile:


#7

Dear all, uboot attached. use with care.


#8

thank you alzhao, any instructions how to install with usb uart?


#9

https://www.gl-inet.com/docs/diy/uboot/

setup a tftp server and be able to access uboot console. Rename uboot to uboot-gl-ar300m.bin (check lu command using printenv)

Then use “run lu”

 


#10

The easiest way to upgrade your u-boot is through web server http://192.168.1.1/uboot.html… just download apropriate u-boot from here http://projects.dymacz.pl/


#11

Hi,

The new bootloader is not working in my router, I have upgraded it and now the router doesnt boot automatically anymore, I have to start manually from command line…

It stops after uboot with this log:

////////////////////////////////////////////////////////

U-Boot 1.1.4-g36de7573 (Feb 27 2017 - 14:14:52)

DRAM: 128 MB
Nor Flash: 16 MB, sector count = 256
*** Warning *** : PCIe WLAN Module not found !!!
NAND Flash: 128 MB, page size = 0x800 block size = 0x20000 oob size = 0x80
Protect off 9F040000 … 9F04FFFF
Un-Protecting sectors 4…4 in bank 1
Un-Protected 1 sectors
Erasing Flash…Erasing flash…
First 0x4 last 0x4 sector size 0x10000
<0x08><0x08><0x08><0x08> 4
Erased 1 sectors
Writing to Flash… write addr: 9f040000
done
Protecting sectors 4…4 in bank 1
Protected 1 sectors
Un-Protect Flash Bank # 1
Hit any key to stop autoboot: 1 <0x08><0x08><0x08>-99

Device 0 bad blocks:
06000000
07fe0000
Found ART,Checking calibration status…
Device have calibrated,Checking device test status…
Device haven’t tested. Please test device in calibration firmware…
Booting image at: 0x9Fe80000

Booting image at 9fe80000 …

Bad Magic Number
ath>

////////////////////////////////////////////

if I type " boot" or “run bootcmd” it start with from NAND else if I type “run blf” it starts from NOR so the nand/nor is not corrupted…

I have reflashed the old bootloader and now it starts corretly again…

I have an ar300m without the 5Ghz wifi,

Thanks,

Guido


#12

@vigans,

OK. I know this reason. Need to find a simple way to fix this. The uboot checks for a testdone flag but in the old firmware there is no. This can be fixed but I need to test first. Please chase me if not come back to you on Tuesday.


#13

@alzhao,

I’m also having this issue with the new uboot. Is there a solution for this yet? If not, is there somewhere where I can get the old uboot image so I can flash it back?


#14

@auty1395

I have downloaded the old bootloader from this post:

https://www.gl-inet.com/forums/topic/uboot_for_gl-ar300m-bin-please-can-anyone-upload-it/


#15

Here is a new updated uboot. Please try.


#16

@alzhao

Hi, with the new uboot the router starts every time from NOR…

I have tried:

  • setenv bootcount 0/3–> starts from Nor

  • setenv boot_dev on --> moved the switch left/right --> starts from Nor

Also, if the LAN and the tftp server is up, the uboot enter in infinite loop searching “openwrt-gl-ar300m.bin” file.

///////////////////////////////////////////////////

U-Boot 1.1.4-g36de7573 (Mar 15 2017 - 14:57:45)

DRAM: 128 MB

Nor Flash: 16 MB, sector count = 256

*** Warning *** : PCIe WLAN Module not found !!!

NAND Flash: 128 MB, page size = 0x800 block size = 0x20000 oob size = 0x80

Protect off 9F040000 … 9F04FFFF

Un-Protecting sectors 4…4 in bank 1

Un-Protected 1 sectors

Erasing Flash…Erasing flash…

First 0x4 last 0x4 sector size 0x10000

<0x08><0x08><0x08><0x08> 4

Erased 1 sectors

Writing to Flash… write addr: 9f040000

done

Protecting sectors 4…4 in bank 1

Protected 1 sectors

Un-Protect Flash Bank # 1

Hit any key to stop autoboot: 1 <0x08><0x08><0x08>-99

Device 0 bad blocks:

06000000

07fe0000

Found ART,Checking calibration status…

Device have calibrated,Checking device test status…

Device haven’t tested. Please test device in calibration firmware…

Trying eth0

eth0 link down

FAIL

Trying eth1

enet1 port0 up

dup 1 speed 1000

Using eth1 device

host 192.168.1.2 is alive

Trying eth0

eth0 link down

FAIL

Trying eth1

Using eth1 device

TFTP from server 192.168.1.2; our IP address is 192.168.1.1

Filename ‘openwrt-gl-ar300m.bin’.

Load address: 0x80010000

Loading: *<0x08>

Abort

Device 0 bad blocks:

06000000

07fe0000

Trying eth0

eth0 link down

FAIL

Trying eth1

Using eth1 device

TFTP from server 192.168.1.2; our IP address is 192.168.1.1

Filename ‘openwrt-gl-ar300m-ubi.img’.

Load address: 0x80010000

Loading: *<0x08>

Abort

Device 0 bad blocks:

06000000

07fe0000

Loading from device 0: ath-spi-nand (offset 0x0)

** Bad Magic Number 0xffffffff **

Booting image at 9f050000 …

Image Name: MIPS OpenWrt Linux-3.18.27

Created: 2016-09-12 10:05:32 UTC

Image Type: MIPS Linux Kernel Image (lzma compressed)

Data Size: 1181639 Bytes = 1.1 MB

Load Address: 80060000

Entry Point: 80060000

Verifying Checksum at 0x9f050040 …OK

Uncompressing Kernel Image … OK

No initrd

Transferring control to Linux (at address 80060000) …

Giving linux memsize in bytes, 134217728

Starting kernel …

[ 0.000000] Linux version 3.18.27 (alzhao@alzhao-ubuntu) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r47065) ) #1 Mon Sep 12 18:05:15 HKT 2016

[ 0.000000] bootconsole [early0] enabled

[ 0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)

[ 0.000000] SoC: Qualcomm Atheros QCA9533 ver 2 rev 0

[ 0.000000] Determined physical RAM map:

[ 0.000000] memory: 08000000 @ 00000000 (usable)

[ 0.000000] Initrd not found or empty - disabling initrd

//////////////////////////////////////////////////////

With the TFTP server active:

//////////////////////////////////////////

U-Boot 1.1.4-g36de7573 (Mar 15 2017 - 14:57:45)

DRAM: 128 MB

Nor Flash: 16 MB, sector count = 256

*** Warning *** : PCIe WLAN Module not found !!!

NAND Flash: 128 MB, page size = 0x800 block size = 0x20000 oob size = 0x80

Protect off 9F040000 … 9F04FFFF

Un-Protecting sectors 4…4 in bank 1

Un-Protected 1 sectors

Erasing Flash…Erasing flash…

First 0x4 last 0x4 sector size 0x10000

<0x08><0x08><0x08><0x08> 4

Erased 1 sectors

Writing to Flash… write addr: 9f040000

done

Protecting sectors 4…4 in bank 1

Protected 1 sectors

Un-Protect Flash Bank # 1

Hit any key to stop autoboot: 1 <0x08><0x08><0x08>-99

Device 0 bad blocks:

06000000

07fe0000

Found ART,Checking calibration status…

Device have calibrated,Checking device test status…

Device haven’t tested. Please test device in calibration firmware…

Trying eth0

eth0 link down

FAIL

Trying eth1

enet1 port0 up

dup 1 speed 1000

Using eth1 device

host 192.168.1.2 is alive

Trying eth0

eth0 link down

FAIL

Trying eth1

Using eth1 device

TFTP from server 192.168.1.2; our IP address is 192.168.1.1

Filename ‘openwrt-gl-ar300m.bin’.

Load address: 0x80010000

Loading: *<0x08>

TFTP error: ‘file /mnt/hdext/openwrt-gl-ar300m.bin not found’ (1)

Starting again

Trying eth0

eth0 link down

FAIL

Trying eth1

Using eth1 device

TFTP from server 192.168.1.2; our IP address is 192.168.1.1

Filename ‘openwrt-gl-ar300m.bin’.

Load address: 0x80010000

Loading: *<0x08>

TFTP error: ‘file /mnt/hdext/openwrt-gl-ar300m.bin not found’ (1)

Starting again

Trying eth0

eth0 link down

FAIL

Trying eth1

Using eth1 device

TFTP from server 192.168.1.2; our IP address is 192.168.1.1

Filename ‘openwrt-gl-ar300m.bin’.

Load address: 0x80010000

Loading: *<0x08>

TFTP error: ‘file /mnt/hdext/openwrt-gl-ar300m.bin not found’ (1)

Starting again

////////////////////////////////////////////////

Thank you


#17

Reflashed the old uboot and even with this the router now starts every time from nor…
I have tried to flash the nand firmware from uboot web page but the process exit with “error 3”:

////////////////////////
Data will be downloaded at 0x80800000 in RAM
Upgrade type: nand_firmware
Upload file size: 9699328 bytes
Loading: ####…####error 3
////////////////////////


#18

@vigans,

Can you reflash the nand firmware from the uboot UI using a different browser or machine if necessary?

Please use the new uboot to do this.


#19

@alzhao

Ok, reflashed all, uboot, nand firmware and nor firmware.
With the new uboot the flashing process is terminated without errors.
Now, the router starts with Nand, to start fron Nor I must set “fw_setenv bootcount 4”, the “fw_setenv boot_dev on” mode is not working… :frowning:

Thank you for your support and time

Guido


#20

@vigans, you are right. boot_dev broken again during bug fix.