AR-300M using NAND storage with LEDE NOR image.

I have a custom LEDE 17.01.2 NOR image and it seems very stable.

Is is possible to use the NAND flash for data storage and if so how?

It is possible. You have to have the Nand driver in your firmware first. Then mount the Nand as a MTD.

@alzhao What is the name of the package for the nand driver? (I am running LEDE 17.01.2 release)

Reviving an old thread here.

Is it possible to access the NAND as a storage device from the OpenWRT v19.07.4 NOR image?

What NAND driver can I use?

You need to compile your own firmware. There will be too much to modify I think. If you use for personal use it is not worth the effort.

OpenWrt Snapshot DOES have a NOR booting version with NAND support drivers. It is found in the NAND category of target ath79. This will be included in the next full OpenWrt release.
Be aware that unless you know what you are doing it can be very confusing about whether you are booting from NOR or NAND.

Are you able to be more specific?

with OpenWRT v.19.07.4 The only image I see is
Atheros ATH79 (DTS) -> Generic -> GL.iNet GL-AR300M-Lite
does this image enable NAND support to use as external storage on the AR300M?

I am currently compiling using
Atheros AR7xxx/AR9xxx -> Generic -> GL.iNet GL-AR300M
which creates a NOR image.

The OpenWrt Snapshot NOR image with NAND drivers is here:
https://downloads.openwrt.org/snapshots/targets/ath79/nand/openwrt-ath79-nand-glinet_gl-ar300m-nor-squashfs-sysupgrade.bin

I’m looking for the required drivers to compile my own image using menuconfig, I am not looking for pre-compiled binaries

Then use the OpenWrt Imagebuilder for your custom image and it will automatically include the NAND support.

Can this be installed via the uboot Web interface?
Thank you very much.

Yes.
For older versions of uboot, select NOR option, in later versions, uboot recognizes the type from the filename.

Thank you very much.

I finally tried this and unfortunatelly after the reboot the unit still shown the GL-inet firmware.
I guess something in the upgrade process went wrong.

Is attaching a UART device the only way to see the upgrade process, right?

Thank you,

Assuming this NOR reflash worked, the device will STILL boot from the default and original NAND flash.
You can either disable the NAND flash (resulting in a boot from NOR) or also flash the OpenWrt Snapshot NAND image.

To disable the NAND boot you have to boot NAND, SSH to it and edit a file or two to make the disable permanent. (I can give you details if you need them).

Yes please if it wouldn’t be much of a hassle the details about how to boot this clean image would be much appreciated, as I’m really not into embedded things. Figuratively and literally lol :stuck_out_tongue:

Thank you very much for your help :slight_smile: