AR-750 (Creta) : free space issue

Hello !

I got my Creta AR-750 today.
It is my first GL Inet Router and I am not very technical, so forgive me if the solution is obvious…
I am just exploring this new world…

I was able to configure some basics things like the SSID, then update the firmware, then I enable the file sharing and it did install something for enabling file sharing.
(but I didn’t see where to share my files and where to access my files then, but it is an other subject, I will search).
Then I went to install Luci, because everybody is talking about Luci so I want to see what it is and how it works.
And here is the issue :

Status : intalled failed
Stderr : No enough flash space.

But… what !? It’s brand new, I installed almost nothing, I played with it 5 minutes, and there is no enough space ?
I put a 32Go micro-SD card… but I understand “flash space” is not my micro-SD card. So… how can I free the flash space ?
What can I do ?

Thanks !!

Here is a post that you may find useful to read:

and another one here:

1 Like

Thanks !

I see lots of posts mentionning the issue of free space but I didn’t really see the solution, or maybe it’s just I don’t understand it.

In the Plug-ins list, I can see 271 installed. Can I desintall some of them to free space ?

Or is there some config to do, to be able to use the micro-SD card space ?

Or I am better to reset to factory settings and NOT upgrade the firmware ?
(But it seems strange to work with an old firmware on a brand new device… Usually the first thing you do when you set up new stuff is to update the firmware… )
Is there security issues of using an old firmware ?

Thanks !

One of the solutions that seems to work is that found by David here:

and here:

1 Like

I will try. I reset to factory. Then I will try.

It may be possible with the micro SD instead of USB stick ? It will be better if yes, I will try…

I tried, but without success.

Adding the SD card as a mount point :


But after the reboot, still no memory added :

Finally … After two other reset to factory… after doing partitions and formatting SD card in EXT4 and NTFS …

I think I succeed !!!


1 Like

oh no … I doesn’t work !
On the Administration panel, if I go to file sharing to install the pluging for file sharing, I still see this :

I understand nothing…

Why I can see 4.2GB free on Luci but still only 2% free on the admin panel ? :face_with_raised_eyebrow:
It’s strange. Is there an issue calculating percentage ?
But it’s OK finally more than 3000MB. It’s just the percentage that is bugued.

Finally everything is OK.
It is juste the percentage % that’s not calculated correctly, seems like a bug.
But I have all the free space I wanted to install everything I need.

For those with same issue, this is the solution :

1- Install AOMEI Partition Assistant Standard. on your computer

2- You don’t want to use all the SD card for the system, so do 2 partitions : one named System in EXT4 (example 4Go, I think it is sufficient), one named Data in NTFS (all the remaining space).
System will be /dev/sda1
Data will be /dev/sda2

3- In Luci, System>Mount Points, add the mount point for the System partition (/dev/sda1) with the type Overlay

Final result :


It worked for me :slight_smile:
Good luck

1 Like

It is a stupid bug…

1 Like

I think Luci is calculating it as a percent of the total nonvolatile ram, and the admin panel is calculating it as percentage of the non-rom part. Or maybe vice versa.