AR-750 v3 firmware?

I see that there are beta versions of the v3 firmware for this router, at

Is this generally “safe” to install and play with? I noticed there are (currently) three versions there, with the same date, which one would I use? I have an AR-750S as well, which obviously came with a v3 image, so I was hoping to unify both my routers to the same major firmware version.


– leif

ofc, you can have a try.

Is this a good version to try:


– Leif

In case anyone wonders, I did install the version above on my 750M, and it works very well!

You are using a firmware with cloud control.

Do you want to try the cloud platform? We have not released it but you can have a beta test.

I honestly don’t know what it does, but sure, I’ll test anything :).

Curious, would I be better off installing



– Leif

Yup, We would appreciate it if you could give us feedback after testing it.

Hello! I tried on AR750 the testing firmware -gl-ar750-3.002-0920_cloud.bin- . I have a wds configuration with an AR750S as WDS-AP and two AR750 as WDS-Clients and I cannot make the two clients having internet connection at same time…maybe it’s me, i’m a new user. I kept options when updating firmware from 2.272 (working fine before).
i did’nt touch anything and it doesn’t work, I check all options were the same but no connection to the internet on both WDS-Clients. I have checked with WinSCP all the etc/config/ wifi-network…files, all was like on 2.272.
I revert and restore factory settings because all the letters or icons were not there in the GUI on firmware 2.272 like before.

You can try the latest one.

Please uncheck keep settings when updating the firmware.

Ok, I will try the last firmware you say, and uncheck Keep Settings as well.

OK testing gl-ar750-3.003-0926 firmware, all ok, just few problems to make 5Ghz working but after few restarts all OK, WDS working fine in 5Ghz.

Just a thing (I have also write it on V3 firmware requests).

  1. No way to see that WDS is connected in GUI (Internet page) like it was in v2.272
  2. Only hosts names appear when hosts connected in 2,4Ghz, in Clients page. When connected in 5Ghz only an icon 5G, no name just the IP of the device connected.


I’ve been running the 3.003 for a few days now, so far so good!

I was going to upgrade my 750S to a similar version, but the .img file I found in the download area for the 750S did not verify properly when I tried to upload it. Is there some trick to installing from the .img for the 750S?

Pls use the .tar file to upgrade.
.img file is used in uboot upgrade

Yep, the .tar worked fine, thanks!