AR-750S and Huawei E3372 LTE modem

Why isn’t there an option to setup NCM mode in GUI?

By default Glinet tries to connect trough QMI mode, which is not working for Huawei modems.

If anyone is interested, it needs manual config to make it work:

config interface 'modem_1_1'
	option ifname 'wwan0'
	option mode 'preferlte'
	option apn 'internet'
	option proto 'ncm'
	option device '/dev/cdc-wdm0'
	option metric '40'
	option disabled '0'

For some reason Modem Name and IMEI is empty. Also Cells Info is empty “unsupported feature”.

It would be also nice to change carrier from GUI.

You cannot set up using NCM via the UI. but you can try to do this in luci. Pls add luc-proto-ncm first.

The UI cannot read modem name and IMEI from USB modems. It can only read from 4G modules in GL 4G routers, e.g. EC25, EP06 etc.

Can you Huawei E3372 works in tethering mode?