AR-750S: can't install OpenVPN configurations


Just got my AR-750S, great so far! However, when i try to upload a zip file (or .tar.gz) with the OpenVPN configurations, it takes all the files and packs it in /tmp, but then fails with an error to “Please Try Again”.

The .zip file is from NordVPN, and I’ve had no problems installing this on the Gl-Inet routers. I also tried cp’ing /etc/openvpn from my other router to the new AR-750S, but it’s not recognizing those files at all it seems.

Any ideas?

The new firmware does have a bug. If your ovpn files are in sub-folders in the zip file, then it may not find these files.

Put all the ovpn files, as well as the cert to the root file then zip it and upload.

Update: Tried again, created a flat .zip file with all the .ovpn files. Note that the certificates are all inside the .ovpn files from my VPN vendor(NordVPN), there’s no additional file with the certificate.


sleipnir (10:38) 342/0 $ zipinfo | head
Zip file size: 20819055 bytes, number of entries: 9703
-rw-rw-rw- 3.0 unx 2808 tx defN 18-Sep-11 07:50
-rw-rw-rw- 3.0 unx 2797 tx defN 18-Sep-11 07:50
-rw-rw-rw- 3.0 unx 2722 tx defN 18-Jun-04 06:41
-rw-rw-rw- 3.0 unx 2747 tx defN 18-Jun-04 06:41

I see the files being unpacked into /tmp/ovpn_upload on the 750S, but I always get the dialog saying to “Please try again!”.

I ran into this issue as well. I have a ar-300m that I was able to upload the ivacy openvpn files to and it asked me for the username and password, I then tried to do the same thing on the ar-750s and it uploads but unable to connect to the vpn. I was however able to use the ovpn files I downloaded from VPN Unlimited with the ar-750s without any issues. Still would like to be able to choose what vpn I do use and connect too.

Fwiw, the instructions on NordVPN are at GL.iNet setup with NordVPN | NordVPN support, and the file I downloaded (and also tried to repackage to flatten the .zip file) are found at

You can upload each ovpn file on its own manually for now. You will see each one in the VPN list and you can select which to connect to.

The putting together the ovpn file though can be tricky and I haven’t found good instructions on everything that needs to be included and in what order. Like I know you have to paste in the cert, key, and ca into the ovpn file when putting it into a single ovpn file. With the ar-300m it then asked me for the login info, with the ar-750s it did not function the same when uploading the zip of all the locations with the ca, cert, key, and ovpn files all in separate files within the zip.

If you look at the NordVPN instructions, you get the opvn files ready to go, with the cert included and all. If your provider is not doing that, send them an email and ask for assistance since the ovpn files should be self contained, it is the proper way to do it, not separate files.

@zwoop you should also upload each ovpn file on its own as the instructions show, not upload the entire zip.

Just to update with my progress. I took the zip file with all the ovpn’s and certs/keys/ca’s and used one ovpn file with the cert,ca cert,ca key, and key and was able to get the ar750s to recognize it and ask for login information. Also confirmed I was able to connect to new vpn.

Wow, that would be crazy, there are 9000+ files in this ZIP file … What changed here?? The older versions of the GL-inet firmware had no issues uploading and setting up the entire set of .ovpn files.

Yea, the original zip I got from Ivacy had all the ovpn files with the propre ca, cert, and key. Using the base ar-300m was able to handle the importation of all of them with a single username and password getting set. But with the ar750s I had to make individual zip files for each location containing the udp/tcp ovpn files with the ca, cert, and key to get it to work. Only then was it able to ask me for the username and password for that location/zip combination.

@zwoop why do you need 9000+ configuration files anyway?

I don’t, but I travel a lot all over the world, and its’ just easier to install the entire bundle. I didn’t make this file, NordVPN (the VPN vendor I use) did :).

Yeah, and if you see the instructions directly from NordVPN, they do 1 file at a time too.
Even though it might have worked in the old firmware, and it might be a bug now, it’s not the smartest idea either way. The UI has to parse all the files and list them each time.

The idea of having VPN servers all around the world is so you can get local services (local tv, things region locked). Using a proper pc program from the provider you can usually see load on each server too. But i don’t think you will in GL ui access one server, do speed test, nope, jump to the next, until you get a decent connection?

I think you don’t need more than a few servers for all use cases. Also remember that NordVPN can change host names at any point, requiring you to reload all the files again.

Have the config for 1 local server near you, a few more around the world and you are good.

I wrote a script that finds the best server automatically when I get to a particular city / country :-). [It uses fping to ping the relevant servers in the state / country, and picks the one with shortest average RTT].

Well, if the intent is that we do not support the bundle any more, I guess it is what it is. I’ll figure out a way to get all the .ovpn files up there. I do find it confusing that the new UI asks for a .zip or .tar.gz file though, why would I want to create a tar-ball (or zip file) for each .ovpn file? That’s pretty darn non-intuitive, and the should at least change that IMO.

The zip functionality is just to support providers doing the old school way of having multiple files, ie having the ovpn file and the certificates separated, making an import easier. This is no longer the preferred way and is not recommended for new openvpn configurations :slight_smile:

If all providers dumped ovpn files like NordVPN embedding the certs into the ovpn file, the feature would not be needed.

Also, here is no direct relationship between latency and transfer speed. The latency, or RTT (round-trip time) measures how quickly a small packet can get from your computer to a server and back, however it does not measure how much data (how many packets) can be transferred in a given period of time. Two different ISPs with the same transfer speed, or even the same computer, at different times and when connecting to different servers can give you very different RTT values. Latency is related to the distance, as well as your ISP’s peering arrangements, network congestion at the time, etc. however it does not relate to your available bandwidth or transfer speed.