AR-750S Problem stopping wireguard


#1

Often but not every time I have problem stopping an active wireguard connection.
The gui says ‘error timeout’.

I then tried to stop by using ‘service wireguard stop’ and the command never finsishes.
I then added ‘set -vx’ at the top of wireguard script and again 'service wireguard stop’
The command seems to hang at ‘flock 1000’, see below.

_procd_wrapper
procd_open_service
procd_close_service
procd_add_instance
procd_add_raw_trigger
procd_add_config_trigger
procd_add_interface_trigger
procd_add_reload_trigger
procd_add_reload_interface_trigger
procd_open_trigger
procd_close_trigger
procd_open_instance
procd_close_instance
procd_open_validate
procd_close_validate
procd_add_jail
procd_add_jail_mount
procd_add_jail_mount_rw
procd_set_param
procd_append_param
procd_add_validation
procd_set_config_changed
procd_kill
procd_send_signal

  • _procd_wrapper procd_open_service procd_close_service procd_add_instance procd_add_raw_trigger procd_add_config_trigger procd_add_interface_trigger procd_add_reload_trigger procd_add_reload_interface_trigger procd_open_trigger procd_close_trigger procd_open_instance procd_close_instance procd_open_validate procd_close_validate procd_add_jail procd_add_jail_mount procd_add_jail_mount_rw procd_set_param procd_append_param procd_add_validation procd_set_config_changed procd_kill procd_send_signal
  • procd_lock
  • readlink /etc/init.d/wireguard
  • local ‘basescript=’
  • basename /etc/init.d/wireguard
  • local ‘service_name=wireguard’
  • flock -n 1000
  • ‘[’ 1 ‘!=’ 0 ]
  • exec
  • flock 1000

#2

Do you try the latest testing firmware?


#3

yes, I run 0915 testing firmware.


#4

have to manually change option enable to 0 and reboot in order to disable wg


#5

this is really annoying.
is there any more info I can provide to narrow the problem down?

Please acknowledge this is being looked into.

thanks


#6

Yes. We are investing this problem.

@kyson-lok


#7

I know the old firmware has this issue, but we had fixed it before. I run 0915 testing firmware and test more than 100 times. I can’t reproduce.

Do you have any other operations?

Could you please upgrade with unchecking keep settings and clean up browser cache? Although it is nothing with it.


#8

reflashed via luci to 0915, with keep settings unchecked.
did minimal configuration (ip address of router, wifi SSID).
restored wireguard config file from a backup.

When I try to connect to my home server I get Error timeout in the UI.
No network connectivity.
output from wg command is weird:

root@GL-AR750S:~# wg
interface: wg0
listening port: 41902
root@GL-AR750S:~#

service wireguard stop command hangs.


#9

@kyson-lok

When I changed my endpoint host from a dns name to an ip address I can connect and disconnect successfully.

Granted I have only tried a few times, will continue testing.

Please try to test using a DNS name for endpoint host and see oif you can reproduce these problems.


#10

@manderss99 Coould you PM your WireGuard configuration file to me? Let me check.


#11

sent configuration in message


#12

connection issue was a bug thats been fixed in testing release.
disconnect issue disappeared when I uninstalled privoxy.

Now I have the disconnect problem again, this time after configuring ddns service.
seems like the same issue with ‘flock 1000’

I use 0929 testing version

ddns configuration with personal details removed:

config service 'Cloudflare_wg’
option service_name 'cloudflare.com-v4’
option lookup_host 'hostname’
option use_https '1’
option username 'email’
option ip_source 'web’
option enabled '1’
option password 'xxxxxxxxxxxxxxxxx’
option domain 'host@domain’
option check_interval '10’
option ip_network 'wwan’
option use_syslog '1’
option interface ‘wg’


#13

service wireguard stop with set -vx:

  • _procd_wrapper procd_open_service procd_close_service procd_add_instance procd_add_raw_trigger procd_add_config_trigger procd_add_interface_trigger procd_add_reload_trigger procd_add_reload_interface_trigger procd_open_trigger procd_close_trigger procd_open_instance procd_close_instance procd_open_validate procd_close_validate procd_add_jail procd_add_jail_mount procd_add_jail_mount_rw procd_set_param procd_append_param procd_add_validation procd_set_config_changed procd_kill procd_send_signal
  • procd_lock
  • readlink /etc/init.d/wireguard
  • local ‘basescript=’
  • basename /etc/init.d/wireguard
  • local ‘service_name=wireguard’
  • flock -n 1000
  • ‘[’ 1 ‘!=’ 0 ]
  • exec
  • flock 1000

#14

please look into this, its really easy to reproduce.
Just configure ddns with interface wg and start and try to stop vpn.

I need ddns support when using vpn.