AR-750S Slate driving me batty with connection drops

I have a Slate with the latest general release firmware (3.101). I run in repeater mode, linked to various wifi sources, some public, mostly private but all 2.4 GHz. While it generally works quite well, right from the get go, I have noticed that it will randomly stop repeating the host. I can connect wirelessly on either the 2.4 or 5.8 interfaces and it will show a connection to the host, yet will not repeat the host. If I switch my user connection to the host network it responds just fine. Switch back to the Slate and no repeat. If I reboot the Slate it will start to work again. Also, if I just leave it for a while, it will generally start to work again.
Ideas?
Thanks -Rob-

1 Like

Update to the latest testing firmware openwrt-ar750s-3.102-0401.tar from here:

https://dl.gl-inet.com/firmware/ar750s/testing/

Connection issues were fixed in the 3.102 versions.

Seems the connection drops and the router will connect it back. There is a short break.

When this happens, you can ssh to the router and get the log using command “logread”. It may contains useful information.

Be sure to make sure signal is good when repeating.

Updated to 3.102 as per Johnex. Will give that a go.
I did a logread as per alzhao, but really wouldn’t know what to look for. I will keep an eye on it though and post again if the problem persists.
Thanks for the suggestions.

Hi,

A quick question to those of you who have tried with the test version, did you notice any improvements in regards to the connection drops ?

Mgns

Honestly, I think it’s actually worse. It seems to drop more frequently but maybe recovers quicker.
I tried looking at the logs and see where the interface goes down but can’t seem to see why.

Thanks for answering. Too bad you you didn’t notice any improvement.

I just downloaded the version available in the test directory. I saw that it was a slightly newer version, 3.104. Let’s see if it improves anything.

I have exactly the same problem and can confirm the 3.104 firmware doesn’t change anything. I’m getting really frustrated with my AR750S and very disappointed by the lack of answers by glinet as it has been more than 5 new firmwares in the last 6 months without any noticeable changes.

Can you please write to us via email support@gl-inet.com and we may ask you help to check.

Actually the connection drop has been improved a lot and that is verified by a lot of users. If you problem is new we like to have another check.

@wellnw

@KamFlyer
Is it possible to send a log and configuration to me, my email address guilin.wang@gl-inet.com

I have been running the 3.104 a couple of days too, and I also experience connection drops once in a while. It also seems that the device hangs for a while which causes the device to not respond at all. After a minute or two it goes online again and I can reconnect to the admin interface.

If you want me to provide you with any logs or other tests, please let me know.

Same here. Connection drops even on 3.104, for now it’s useless device for me.

Hello!
I don’t know if this can help:
When a new firmware comes out, I always try to make my repeater connection (2,4Ghz Ch 11) through the UI. In testing firmware 3.102 (I don’t try 3.104 yet) everything was fine, there were no disconnections but then they started again.
My solution is to make the connection through luci (wireless>scan>join) and I don’t put neither wlan-sta in wireless nor wwan in interface as names and I never have any disconnection again. (Of course you cannot manage wifi connection thru UI). I connect to a public antenna that is 50m outside my house and there are 4 connections available, two in 2,4Ghz and two 5Ghz, all same SSID name different MAC address.

I have thought that the problem is related (in my case) to the fact that when several networks with the same name (Hotspots, hotels, airports etc) are found with different MAC, the router connects to one of them but change connection in relation to the signal strength and conflicts are generated. You should allow the possibility to choose the connection SSID along with MAC in the UI and make it fixed with this MAC only.
Thanks

My situation is almost identical. Multiple access points with the same ESSID.
I don’t quite understand how you are connecting. Can you be a bit more specific?
Thanks

Hello! I use Luci to establish connection to the public antenna when the UI connection manager begans to drop my connection.

  1. Go to http://192.168.8.1/cgi-bin/luci/admin/network/wireless (your default IP Luci page of your router if it’s another IP modify it)
  2. Click Scan in 2,4g or 5g as you want to connect to 2,4g or 5g antenna then choose the SSID you want to connect to, clicking Join Connection blue button.
  3. In the Name of the new network I put a name like “Antenna_2g” for example. Assign WAN (red) Zone
  4. Now in the newly created page in the Wireless Network “Antenna_2g” go to Interface Configuration (bottom of the page) and click Advanced Settings. Here you can put also “Antenna_2g” or another name that will appear in the Interface section in Luci (where you can change MAC if you want).
  5. Save.

I think I do this things OK but I’m quite a newby in OpenWRT, Maybe someone else have more technical and accurate procedures but my connection to the public antenna is rock-solid with this method and never disconnects.
Good luck!
Sorry if my English is not very correct.
Bye

I’m a little late to the party, but I have had the same problem. I downgraded to 3.100 and the problem mostly went away. I tried the new 3.104 with some changes made by a support guy, but there was no difference. I use the WAN input for internet (connected to a PC that uses ‘Connectify’). A few days ago, after upgrading back to the new 3.104, I disabled the 5G band. The only enabled radio I have is the main 2.4G band. So far the router has been up for almost 2 days without a disconnect. This may be a record for me. Some of my wifi devices are 2.4G only, so I can’t live without that band. I can live without 5G if I have to. I’ll report back if problems start again.

Hello! I have firmware 3.102.
I connect to the wifi public antenna with 2,4G (ch11) and I have 2 WDS routers (AR750) connected to this AR750S using 5G (ch149) and I have not disconnections. All also have 2,4G working (ch11, 6 and 1). All my devices connect to the 2,4G.Only my laptop is connected in 5G to the AR750S In my country is 110V, if it could be a transformer problem also…my config is working fine. I have noscan=1 (no more than 2 neighbour wifi around here).
Bye!

I spoke too soon. I have a tempstick that talks to its mothership once per hour. I get multiple emails per day telling me that it lost connectivity, which I am assuming means that it the router loses its connection to the internet.

I am downgrading back to 3.100 to see if that solves the problem.

1 Like

I live in a motor home. Motor homes have a well-earned reputation for being poorly insulated. Here in Mesa, AZ it is starting to really warm up.

I keep my internet electronics in a cabinet (hotspots, a small tablet, USB/ethernet adapter, router. I began to think about the temperature of the equipment in the cabinet. I temporarily relocated the router into another cabinet. Unfortunately, I moved it to a location that was even warmer first thing in the morning. I couldn’t stay connected to it on the first morning.

I have currently mounted it outside my electronics cabinet where air can circulate around it. It appears to be much more stable! I have installed the 3.102 firmware with Adguard and haven’t had a disconnect in a couple of days.

I may reinstall it in the cabinet to see if the problems return. I’ll shoot it with an infrared thermometer and see what the temps are when it fails and when it doesn’t fail.

Mine is also in an RV but is in probably the most temperature stable location in the unit. Still having stability issues. I’m currently running 3.104. A GL-iNet tech looked at my config and made a couple of changes that seemed to help. Unfortunately, I had a power drop and lost those changes. I am trying to get back to that state now. The change was mainly reducing the bandwidth on the upstream interface to match the upstream AP.