AR-750S uboot flash failed

Hello all,

I tried to update a new AR-750S to the latest version of U-Boot ( using the U-Boot webpage. I never received any conformation that the flash was successful or that it had failed, so after about 15 minutes I unplugged it. Now when plugging it in the power light glows dim and nothing else happens. Holding reset while plugging it in gives the same result. I have a UART connector on order. Should I be able to flash U-Boot via the serial interface?

Thank you

Hi @bairdi -

Depending on how broken your uboot is, you should be able to still do a kermit upload over it. I’ve used this gist for years when fixing dead NetGears, but not this specific device. You’re going to need to know the entry points for your system or you’ll nuke it - if it’s not completely dead.

See what you can find once you attach the serial console. You can always use minicom or a similar tool, but I find that the above script just works well for me, since I’m a Linux-on-the-desktop weirdo.