AR150 is not visible after making any kind of changes

Hello all,

I have been using the AR150 for about 2 months now. It was working fine till about 2 weeks ago. Since then I’m having a peculiar problem consistently.

If I make any kind of change to the device settings (Wifi hotspot, wifi password, timezone, router SSID, etc), the router becomes invisible to me over wifi. My phone or laptop cannot connect anymore. I have to do a complete system reset.

I tried changing only 1 thing at a time, like just change the SSID. Even then, the same thing happens. Now this did not happen before as I mentioned earlier. I also upgraded the firmware to v2.13 found on the download page. I tried changing 1 setting and again the same problem.

When i use it with everything at default settings, it works. I can also ssh into it. Can someone help me with this?


When you upgrade to 2.13, pls don’t keep settings. If you did, just do a reset.

Next, make some change, like change ssid, password, timezone etc., if you have problems, please feedback:

  1. Does the red led still light up?
  2. ssh to the router, give us your /etc/config/wireless content, output of "ifconfig"

I have tested AR150,I don’t find you problem.How do you change the device settings? I use web.I will give you some illustrations to confirm it.

@xiaoxin Yes I am using the standard web interface, just as I always have.

@alzhao I have already reset it like 10 times. If I make any change, the router goes invisible, and the red light keeps blinking. I have attached the output from the 2 commands you mentioned. The name is currently the default one, since I cannot change it.

Its just like what any normal user would do, changing SSID, password, etc. It used to work flawlessly before, but not anymore. I haven’t made any other change in the hardware or firmware.

Is the attached a working one?

I checked that you configured repeater and the repeater works fine.

I need the same info after you make changes and cannot see wifi. use a cable, connect to it and get these info please.

@alzhao … The attached is the original working one after reset. how can I get the info after changing if I cannot even connect to it?

This is not the one just after reset. After reset, you should not have any of these settings as “repeater” or “wwan”.

It means that you have setup the repeater and it is working.

To reset, hold the reset button for more than 10 seconds and release. You will see the LEDs flash one by one sequentially.

You cannot even connect using cable??

I guess the problem is that: you have a repeater now and you modify wireless settings, causing wrong channel settings and the radio cannot turn on.

@alzhao ok don’t ask me how, but somehow it’s working fine now. I changed settings like SSID, password, channel and there doesn’t seem to be any problem as of now. I’ll report back if this changes.